Android Roon Remote Laggy To The Point Of Uselessness

Roon Core Machine

Roon CORE running ROCK Version 2.0 (build 1353) production
Intel NUC11PAHi7
11th Generation Intel Core i7-1165G7 @ 2.8 GHz – 4.8 GHz Turbo, 4 core, 8 thread, 12MB Cache
28W Intel Iris X Graphics, up to 1.3 GHz, 96 EU units
16GB DDR4 RAM,
256GB PCIe Solid State Drive (SSD)
Ethernet connected

Networking Gear & Setup Details

Linksys WiFi 6e Triband Router MR7500
Three Linksys Atlases (MX8503) ← the Roon Core is on one of these, not the primary router itself.

Connected Audio Devices

McIntosh MAC7200 | Ropieee box | Three Windows 11 PCs via USB DACs | A Samsung S23 phone.

Number of Tracks in Library

12,121

Description of Issue

The problem is on my Samsung S23. The Roon Remote app is laggy to the point of being useless now. Every single time I want to use it, I have to wait about 10 seconds for it connect to the server. If it can’t connect, I’ve had to disable and enable the Wifi. That was fixing it for a while. Today, that didn’t work. So I rebooted my phone, the Roon core, and my router. But I’m still having a huge connection delay on my phone. And it’s only the phone. The Windows PCs can connect no problem (they’re networked). I’m not having Wifi problems with anything else in the house.

I have no idea why this is happening, but it’s very annoying. I can’t really use Roon without the remote app working.

Thanks.

Hello? Anyone home?

Dont know if you still having issues but maybe have a skim though these 2 threads if you havent already

Thank you, sir! I will dig into that.

So… at this point I have to ask. Will there be any actual support in this support forum? I have yet to receive any kind of official response. And I’m still having this problem.

Hi @Shane_Morales,

Based on the description of the symptoms and the devices involved, the most likely culprits here are:

  1. IGMP Snooping on the Linksys Atlas mesh system, since the RoonServer is wired to one of these. I’d make sure any settings related to this are enabled.

  2. Seamless Roaming on the Linksys mesh system. I’d verify this is also enabled.

If you continue to have issues, if possible, try hardwiring the RoonServer machine to the main router and then rotate to mesh nodes one at a time to identify where multicast or other traffic is failing to forward properly.

Thank you for your patience!

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.