Android Tablet - very very slow loading new song info


Using Roon Remote with an Android (v.6.0) Tablet (BQ Aquaris M10).

Core, in W10, is connected using ethernet.
Tablet is connected via WIFI 2.4 Ghz. signal strengh is very strong)

When changing to a new song, the info in now playing or queue (cover, etc.) takes 3 secs if I just open the Roon Remote, that´s ok, but in minutes it begin to take more time to load the info, as much as 35 secs. In this time the Roon interface is freeze, nothing can be done. So, mainly unusable.

Discover section also veryyy slow, also unusable.

With a Samung S7 Roon Remote (android 7 and 8 tested) works perfectly (just 1 second to load the new song info)

Help please.


Thanks for reaching out, @kursaal!

Has this behavior always occurred for this device or is it a new behavior?

How is this device connected to the network? Is it also via 2.4Ghz WiFi?

Are there any other applications being run on this device at the same time or is it just Roon?

Have you tried doing a hard reboot on the device?


  1. I had begin to use the tablet as an all time Roon remote three weeks ago. From the begginig the problem is there.

  2. The S7 and Tablet are connected to the same wifi-router. The phone to the 5Ghz and the tablet to the 2.4Ghz. The tablet is located just half a meter from the wifi router and the signal strength, as I said in my initial post, is very strong.

  3. I just uninstalled almost everything when I decided to use it as Roon Remote. Anyway, sometimes may be there are another apps running. I´ll check closing everything but Roon.

  4. If you mean wipe data / factory reset, no, I´ve not try it. If you consider it necesary, well, I´ll do. Let me know please.


Ok, I just did the wipe data / factory reset to the tablet. No other apps running. Also connect it to the wifi 5Ghz band (very strong signal-very near the router).Since 15 minutes ago Roon remote running. First 5 minutes the transition between songs, loading the new song cover, took no more than 3 seconds, ok. After those 5 minutes, again, begins the delay. Now is taking 12 seconds to load the new cover, and while doing it, nothing can be done in the interface, freeze. In half an hour I bet the transition, as before the hard reset, will take more than half a minute :frowning: (update: confirmed, after some more minutes playing the transition between songs takes 35 secs)

So, nothing change after the wipe data-factory reset, still the same problem.

Let me know please. Thanks

Thanks for the update, @kursaal!

When this behavior occurs does closing and restarting the app resolve (temporarily) or does the device need to be rebooted?

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.


  • closing and restarting the app (Roon Remote) resolve (temporarily) the problem.

  • This is the data you ask me about. I began to take note of timestamps while listening to a shuffle list that was playing some minutes before:

19:23 - 8 seconds in the transition, and interface freeze, between songs.
19:27 - 10 seconds…
19:33 - I press skip forward and jump to next song
19:41 - 12 seconds…
19:45 - 13 seconds…
19:48 - 15 seconds…
19:51 Roon Remote close-quit on its own. I open it again. Syncs with core almost inmediatly. Song is playing…
19:55 - 2 seconds

Thanks, @kursaal!

Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.


Is this not a case of a no name, low spec, old Android version tablet that just is not up to the task for Roon?


Well, at least in Europe, BQ is not a No Name brand. And the specs, including Android 6, I think are more than enough for roon remote. Anyway, sure Dylan will let me know :slight_smile:

HI Dylan, just to confirm that you received the diagnostic report of my core and, if your answer is yes, any clues?. Thanks.

Hey @kursaal,

I appreciate your patience here! I had a chat with the team about their findings here and I wanted to reach out about the next steps here.

Unfortunately the diagnostics report didn’t give us a clear idea of what may be happening here. There may be some CPU throttling on this device causing this, so the team has recommended checking to see what your power saving settings are currently on the device.

Additionally, we are currently working on some changes to our Android application that may yield some change here. I don’t have an exact timeframe for this, but know that it is actively being worked on and I’ll be sure to keep you updated as soon as more news about this becomes available.


Thanks for your feedback Dylan. From the very beggining, just after restoring android to factory, I set no battery optimization at all for the Roon app. Well, hope those future changes to the Roon´s Android aplication will solve this problem with Android 6 in the BQ tablet.

We´ll see. Thanks again.

With the new reworked and brand new Roon remote for Android that has been release today, the problem has gone. Now works perfectly.

Well done Roon Team!!


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.