Android USB DAC only plays at 16/44.1 [Ticket in]

I haven’t had the same issue as @Michael_Harris either.

Like him, I’m content with 16/44.1, but helping iron out bugs helps Roon and others.

I’m going to have a play with settings etc later and see if I can ‘break’ my setup to help see what could be causing this.

Could be the Android version of his daily driver phone. He’s mentioned he’ll try his Pixel.

Yeah absolutely a good idea to try and break it, I’ll do the same.

I was only pointing out that it’s not default behaviour, apologies should of worded that differently.

1 Like

Yes I am away so it is the plan for trying it this evening.
It could be the DAC hence my question as to what devices are supported to what level

1 Like

No need to apologise. I am rush typing myself as I’m at work. Getting paid by my boss to be on Roons forum. :rofl:


So I tested this FIIO KA2 on my pixel 6A tonight and the same results, so I have to assume that it is a compatibility issue with this particular DAC.

Can somebody please confirm if this is correct?
All sounds great to me as I said before, but best to understand what is the expected result.

Have you got the FIIO control app on your phones? Wondering if there’s a setting in the app that needs adjusting

1 Like

Good thinking Lewis and I had not thought of looking there. But sadly it’s not an option.

If I use Android Audio and turn off USB the LED turns Blue as opposed to the current yellow for 16/44.

I did just notice this though which seems to confirm that ARC is reducing the bit depth before sending it to the DAC.

Yeah, seems to be a Roon thing.

Having a quick search on Roons message in your screenshot, for better understanding on my part, it might be Roon doing you a favour.

  • Dithering is the process of adding noise to a signal, in an effort to mask and randomize higher-order harmonics, and in turn, make quantization distortion less perceivable. Dithering should only be used during the mastering process, and only when the bit depth of a signal is being reduced.*

A false optimisation from Roon, maybe?

1 Like

Quite possibly, but this is early testing software and we are providing feedback.

Going to have to unplug the DAC soon though, before it burns me :joy:
I don’t think it normally gets this hot, but that will have to be an investigation for another night.
Maybe time to turn on the Sonos Roam a go👍

1 Like

Unless it’s not meant to I don’t get lossless via car/van USB Android Auto. I do with iOS devices.

Tried USB Audio Player Pro, no USB DAC being detected.

Might be a different issue to @Michael_Harris as mine is being being sampled to Android Audio 24/48 and isn’t picking up USB output. With my AQ Cobalt it works.

Yes that one is not seeing the USB audio DAC.
Interesting I was able to make something like this happen last night.
I was playing a podcast and closed it and started playing audio and it didn’t work, then it worked on AUDIO only. Try removing the DAC (if you have not tried that already) and putting it back in.
I also have a couple of mini DACS that just don’t work and give an error message

1 Like

Seems similar to my report for Chord Mojo here - which was solved by reinstalling Arc, somehow. It now recognises the Mojo with bit-perfect passthrough.


I’ll try it. Thanks

Hey @Michael_Harris ,

Thanks for sharing your feedback with us. We can’t reproduce this issue internally, but we’ve enabled additional logging for your account. Can you please follow the steps below and let us know once done:

  1. Restart Roon Core and ARC
  2. Reproduce the playback problem
  3. Note the time of reproduction
  4. Let us know in this thread time of reproduction and the device/phone with which you did this

Thanks in advance, we really hope we can resolve this one.


Thanks I am away until tomorrow and I will do that then and feedback

Hi @vova just to confirm I rebooted my Core last night and both of phones this morning.
I started playing music at about 11 AM this morning if you want to look at the logs.

Both my Google phones are still playing 16/44 down sampled as before.
Let me know if you need me to test anything else.

thanks, we are going to look into your report

Thanks and just let me know if you want further information

Hello all, it’s much appreciated to see Team Roon working on the bit perfect issue on android.

I am coming across the same problem as @Michael_Harris

For songs with bitrates higher than 16, they are resampled to 16bits.

I’m using a samsung galaxy s20 with android 12, and the dac i’m using is a&k sp2000.

Hope the team could take a look at it.

Thanks @Bong_Li as I was starting to think it was just me :wink:

Good to know I am among friends now :rofl: