Another disappointed lifetime subscriber trying to be patient

Core Machine (Operating system/System info/Roon build number)

Roon Server v1.7 build 571 on a headless Mac Mini 2012 with Mojave; i7 x 2.3 GHz with 16GB RAM and Samsung SSD. Library is on a Synology NAS, and everything is hard-wired. This is a dedicated system. The only things it runs are the OS, Roon, and a backup program for the NAS. Nothing has changed about the system in several years except OS patches.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Mac Mini and NAS are hardwired to Cisco switch. Remote controller is iPad or MacBook Air via wifi to Airport Extreme. Internet service is Cox “Gigablast”. Modem is Arris DOCSIS 3.1.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Mac Mini server is connected to DAC in main system via USB. Sometimes I listen on iPad or MacBook Air with headphones.

Description Of Issue

I’ve been a subscriber to Roon and Tidal since 2015. Until a few months ago, my listening experience looked like this:

  1. Pick up iPad and start Roon
  2. Select music from library or Tidal and enjoy.

Here is what it looks like now:

  1. Pick up iPad and start Roon.
  2. Wait 30-40 seconds and receive error message that Roon can’t locate the server.
  3. Quit Roon and walk upstairs to log in to the Mini.
  4. Stop and restart Roon Server.
  5. Walk downstairs, pick up iPad and restart Roon.
  6. Wait 30-40 seconds and receive error message that Roon can’t log in to Tidal.
  7. Retry login and wait 30-40 seconds.
  8. Ignore error message from Roon and browse to Tidal.
  9. Select music from library or Tidal and try to calm down.

I have been patient assuming Roon will solve this and have not wanted to fan the flames along with the many others who seem to be having similar problems. But when I read the dismissive responses from the community to the complainers, I get frustrated and begin to wonder if there really is a general understanding of the severity of the problem.

What troubleshooting have you tried?

  1. Installed Roon client on a desktop hardwired on the LAN to take wifi out of the equation.
  2. Uninstalled Roon Server and reinstalled (on the same computer).
  3. Restored Roon Library from a recent backup.
  4. Tried to disable the Tidal service, but even after I disabled it within Roon it still gave me the login error and would not run. Very puzzling.
  5. With Tidal disabled within Roon, disconnected the modem so that there was no internet service, but Roon would not function.

I suppose possible next steps would be to relocate the Core to a different computer and use the full install instead of Roon Server, but it is painful and time consuming to rebuild the library so I am seeking direction before going there.

Roon Support should respond to your post. In the meantime you may want to check your log files to see if you can spot an obvious problem.

https://kb.roonlabs.com/Logs

Good Luck.

This sounds like a network communication issue. Have you restarted the Apple Extreme?

I think my Mini is a circa 2015. When it awakens from sleep it is an absolute dog, almost completely unresponsive. Don’t know if that’s your issue or not. Have you thought about running some utilities on the Mini to check its health? With that much Ram I would expect very little if any disc i/o. Maybe there is a way to check if memory access is up to snuff? I did a quick check on MAC rumors and their are a few people that reported issues with 2012 Mini’s and Mojave.

I only have a year subscription but I bit the bullet And migrated my core to a SGC ST i5. Nice simple solid and easily administered from iPAD. But if I can’t solve the SQ issues with Roon (vs my endpoint running MPD) I’m dumping Roon and the SR i5 and just using Manic Moose and MPD.

This might be your issue. If you look at the Networking FAQ: https://kb.roonlabs.com/Networking_Best_Practices

It says this (bold my emphasis):

Finally, we strongly recommend against using Apple network devices such as the Apple Airport Extreme and Airport Express (note: it’s fine to use the Airport Express as an Airplay device). To ensure the best performance, we recommend against using these devices.

2 Likes

Thanks for your response. Yes, I’ve restarted the AE several times. This is not a wifi related issue. It also happens on the Ethernet LAN.

Thanks for responding. The troubleshooting measures I described in an earlier post indicate that this isn’t related to the AE. And if there were some kind of incompatibility, why would it have not shown up for the first 4-1/2 years of Roon use? The rest of the LAN, which includes several family computers, printers, scanners, etc, works fine. What doesn’t work is Roon.

Thanks for your suggestions. According to iStat Menu and Drive Genius the computer is in good health and there is no problem with memory access or i/o performance of the SSD.

Thanks. I looked at the logs, but I have no context since I don’t know what a normal log is supposed to look like. I’ll wait until Support requests them.

BTW, the server Mini is headless so I have it set to never sleep.

Hi Tracy- I have the same modem but mine doesn’t have a router. Was yours supplied by Cox with a router combined?

Tracey,

I am an Apple Consultant and the first thing I can tell you is that Apple networking products have been deprecated for several years. The first thing I would do is ditch the Airport. Even though you stated that you tried it on Ethernet, it is not conclusive that the bottleneck is not the Airport.

Secondly, you have a Synology so why don’t you run the Roon server on the Synology and take out the extra “hop”.

I have been successfully using a Synology Server for Roon as well as storing my library on the same NAS. As for wireless, I use and recommend to all my residential clients Eero which is amazing when properly installed.

2 Likes

Mark,
It wasn’t supplied by Cox, I bought it. You are right, it doesn’t have a router - the Airport Express is the router.

Jerry, thanks for your helpful response. My Synology is a few years old and doesn’t have the processing power to run Roon server natively (DS1512+). I am aware that the Apple hardware is beyond end-of-life, but testing and measurements indicate that it continues to perform better than many contemporary routers. New is not always better, even in technology. In any case, the throughput and bandwidth are more than adequate to handle the demands from Roon. Wireless connections are always to be suspected, but in this case the problem persists even with fully hardwired connections. I have tried replacing ethernet cables and switches to the extent that I can. The in-wall cable is a CAT 6e home run to the main Cisco switch that tests out good.

All things are possible, but I do not think this is a hardware or network related problem. Nothing else on the network is having issues. I believe it stems from the recent compatibility problems between Roon and Tidal that have been reported on this forum by many in the last few months.

Hi @tLea,

I’ve given our latest update on this issue here:

While the behavior has been improved (you can retry instead of log in), we aren’t able to completely resolve issues that are stemming from environmental slowness.

As we note in our Networking Guide, we recommend against Apple networking products. It’s hard to say if that is the exact cause of the issue here, but it’s definitely a possibility. It’s also possible that the switch, particularly if it is managed, is playing into things as well. I’d recommend starting with adjusting your network configuration and let us know if there is any change!

1 Like

Tracey,

Understood. However, if you hired me for the job I would have you let go of the deprecated, older technology of the Airport system from Apple. There is no badge of courage, carrying the torch for this product and I can tell you that it is underperforming, regardless of whether it solves your issue.

That would be my first place to start. You have a lot more dollars at stake. It’s like clients of mine who endlessly discuss whether they should upgrade their iCloud storage and then end up paying more in consulting time to discuss the mater. Like they said in Frozen, Let It Go.

I have my occasional issues with Tidal, Qobuz and Roon but for the most part, the technology works. I have updated, modern equipment that didn’t cost me an arm and a leg - i.e. I use a Raspberry Pie and a Khadas Tome Biard. Definitely not high end. All is good and very few connectivity issues.

Amen! Right on, Dylan.