Another odd screen issue

I have two Raspberry pi 3 endpoints with the official 7 inch screen in different rooms. Roon is running on a dedicated server using the Roon rock software. Been running ropieee for ages with no problems - until a power cut last night.

Both endpoints had rebooted but stop at the “We’re ready…” message, both play music fine except that there is no album display. Tried rebooting everything including the Roon server, checked that the extensions were enabled and the audio settings are OK in Roon, downloaded ropieee and reflashed new sd cards, checked the settings again. Every time, ropiee stops at the “we’re ready…” message. On the ropieee web page, the display tab is active and I can make changes.

And now I’m out of ideas! Music flows, the screens show text only and no graphics. Am I missing something obvious?

Many thanks, Rick


Can you go the ‘advanced’ tab of RoPieee’s webpage of one of the units and hit the ‘send feedback’ button? and then provide me feedback?

Hi Harry - many thanks! The identifier is 7c02701e19365b57.

Hi Rick,

I’ve found the issue.
I’m preparing an update that will fix this and give you your screen back.
If everyhting goes according to plan this update will be out today.

Regards Harry

1 Like

Harry - you are a gentleman!


Update is out there. Just reboot your device and it will update.
Within 10 / 15 minutes or so you should have your screen back.

Regards Harry

We have life! Very many thanks Harry.

1 Like

The touch screens on my two Audiophonics RaspTouch I-Sabre ES9028Q2M units are no longer working properly after RoPieee /Roon upgrades.

On my home setup it no longer shows what’s playing. It’s always ‘unknown’. Just after the last update I found the extension turned off, but turning it on made no difference. RoPiee Remote Control 0.8.3

Package Version
ropieee 20180812-1
ropieee-version 148-1
ropieee-web 20180729-3
linux-raspberrypi-dsd 4.14.56-1
qt5-base-ropieee 5.11.1-1
qt5-declarative-ropieee 5.11.1-1
qt5-graphicaleffects-ropieee 5.11.1-1
qt5-quickcontrols2-ropieee 5.11.1-1
qt5-xmlpatterns-ropieee 5.11.1-1
ropieee-remote 20180520-1
ropieee-touchui 20180812-1

On my work system it seems to show the first track played, but doesn’t update for other tracks.

UPDATE: I just went to Send Feedback on my home unit and noticed the Restart Roon Remote Extension button. Doing that seems to have fixed the problem. Will try it at work later.

UPDATE 2: First album finished playing. Started a new album.What’s playing details don’t update. Touch controls seem to be working okay, but details of last track of previous album still displayed. Have sent feedback 27cb41efa41f14bb

From the logs everything seems to be ok.

I do see that you’re running things in a grouped zone. Have you tried going back to a single unit to see what happens?

Regards Harry

I just tried that Harry. Problem still persists. Only updates if I restart the extension.

And then it just stops after a while??

Doesn’t move on to the next album. Plus, for example, I just started playing an album on my work system. But the screen stayed on the time. When I touched it, it came up displaying the details of what I was playing yesterday, not what I just started playing.

Either something to do with the recent Roon update, or the latest RoPiee update, has introduced this problem.

I am having a similar issue. The extension seems to crash, as the display never updates either the progress or subsequent tracks or albums. If I restart the extension, the display updates but then freezes.


I’ll look through the logs tomorrow.

I can’t uncompress the archive. Can you try again?

This is a tough one guys as this does not happen on my system. Any hints on how to reproduce it would be nice.

So @Lloyd_Borrett, this ‘does not move to the next album’ means that it doesn’t respond to touches? Or are you saying that it doesn’t even follow Roon properly?


Working on the assumption that it is network related and Roon core related, I rebooted some stuff, and that seems to have fixed the problem for now (rebooting the display had no effect before).

To be clear, in my case the display did not follow Roon.

I’ll have some time tomorrow to test further.

It responds to touches.It doesn’t update the what’s playing details of artwork, track, album and artist.

So say I start playing an album. That album goes okay. But if I then start another album, or radio kicks in, those details don’t get displayed.

UPDATE: I just rebooted the ROCK on my work system. Problem seems to be now gone. Will try that later on my home system.

UPDATE 2: Reboot on home ROCK seems to have fixed the problem there as well.

I’ve had a rash of odd screen issues which were different on different RPi endpoints. Harry’s update solved the main one, reflashing and starting from scratch solved the second and rebooting my ROCK server solved the third! Looks like the update to the underlying OS had some very random effects!

Issue occurred again today. Music playing and the RoPieee display didn’t “wake up” (stayed showing the clock). Steps I took:

  1. Feedback before restarting extension: 99a7c6ed72ccc535
  2. Feedback after restarting extension: 0516c2e92ae99f02
  3. Display showed the album art, but immediately froze (no update of timing)
  4. Restarted NUC running ROCK. (eg not just server software)
  5. Display works as expected. ed55284c00e78432

I wonder whether the latest Roon update is causing some issues with extensions, but I don’t know how to troubleshoot further. Music always plays fine, whether RAAT endpoints or my remaining SONOS endpoints. I have made no recent network hardware changes, and no new extensions or change of end point hardware etc, so I am unsure where to look. I record ping intervals to each endpoint every 10 minutes, and there has been no change that I can determine:

@support, is there any logging in ROCK that can be used to determine why the connection is (presumably) failing?

@Nathan_Wilkes, @spockfish This is probably caused by the updated transport API. In version 2 elapsed time is sent to the extension via a separate message. The extension has to be updated to support this.