Another “Roon Could not connect to HQplayer” problem

I have had HQPlayer embedded for 1 week and it has worked fine.
Now all of a sudden Roon will not connect to it.
HQP is on the same machine as roon core and therefore it is set to “localhost” in the roon setup
Ubuntu 20.04 LTS
In the web ui of HQP, I cannot access the “main”, “library” “convolution”, “speakers” pages any more – if I click on them, it just takes me back to the config page.
I tried reinstalling HQP using dpkg but no change
Is the install corrupt?
HQP service is running fine it seems:
hqplayerd.service - HQPlayer Embedded daemon
Loaded: loaded (/lib/systemd/system/hqplayerd.service; enabled; vendor preset: enabled)
Active: active (running) since Fri 2021-10-01 23:30:27 BST; 8min ago
Main PID: 929 (hqplayerd)
Tasks: 7 (limit: 9046)
Memory: 45.8M
CGroup: /system.slice/hqplayerd.service
└─929 /usr/bin/hqplayerd

Oct 01 23:30:27 vassal systemd[1]: Started HQPlayer Embedded daemon.
Oct 01 23:30:34 vassal hqplayerd[929]: active locale: C.UTF-8

If I less /lib/systemd/system/hqplayerd.service I see a line: “EnvironmentFile=-/etc/default/hqplayerd” – the file / etc/default/hqplayerd does not exist – is this a problem?
Tried rebooting multiple times
Tried rebooting NAA
HQP log says it can see the NAA fine

How do I get HQP back working?

Please help

Can you share screenshots of everything you see on the Config page?

And what your DAC is and how it’s connected to HQPlayer

The more you share the easier it becomes to help troubleshoot. Otherwise it’s hard

1 Like

Thanks for the interest - it is much appreciated.

Here’s the config page - if I click on the links to “main”, etc at the bottom of the page (as described above) it just takes me back to this config page. The “restore”, “About”, “Authentication”, “Key” and “Log” links work fine but the others don’t work and just take me back to the config page. This leads me to suspect something wrong with the HQP installation.

I tried uninstalling hqplayerd using apt-get and reinstalling using dpkg ( sudo dpkg -i hqplayerd_4.25.2-85_amd64.deb) but this has made no difference. Is there another package I should uninstall perhaps?

Dac is a Chord Qutest connected via an Allo USBridge Sig via USB. The USBridge has a DigiOne Sig on top, which is also connected to the Qutest via Coax for a bit of variety. All this still works fine as both the Qutest USB and the DigiOneSig show up in roon as native devices. The output of the Qutest goes into an analogue input of a Naim 272 preamp and this all works fine - sounds come out no problem. HQPlayer can access either the USBridge or the DigiOneSig and I can set them in the config page, but I can’t access the HQP via Roon now. My gut feel is that the HQP install is corrupt somehow.

This is a really strange one and I am baffled. Any light will be much appreciated!

Thanks again

Can you show a screenshot of Roon audio settings page?

Can you “disable” those devices in Roon

Reboot all your, including DAC and USBridge

This happens when HQPlayer is in “check your configuration” state, and in such case it won’t let Roon or other control applications connect.

Practically always reason is that HQPlayer cannot access the DAC. For example if stored DAC identifier has changed. You may need to select your DAC again.

When audio device is behind a NAA, stored identifier is name of the NAA plus name ID of the DAC. Output device is thus combination of two names.

Thanks to both. Short version: I fixed it by purging hqplayerd and reinstalling.

Long version

I tried all the things (mainly disabling the devices in roon then reslecting them in the hqplayer web ui) but still no joy. I did notice however in the log an error:

! 2021/10/02 09:54:22 clPlayerDaemon::CreateEngine(): clHQPlayerEngine::Initialize(): clString::ToUInt(): not an integer

(a bit more of the log is pasted below for context)

I tried removing hqplayer with apt-get purge to delete all the configs and reinstalling. I also reinstalled the dependencies as well. Then I reinstalled hqplayer with dpkg and this has worked!

Thanks for the help. A bit more of the log file is included below in case it is useful.

Thanks again - much appreciated

2021/10/02 09:54:21 asoundlib version: 1.2.2

  2021/10/02 09:54:21 Found ALSA device: hw:CARD=PCH,DEV=0 - HDA Intel PCH: ALC892 Analog

  2021/10/02 09:54:21 Found ALSA device: hw:CARD=PCH,DEV=1 - HDA Intel PCH: ALC892 Digital

  2021/10/02 09:54:21 Found ALSA device: hw:CARD=PCH,DEV=3 - HDA Intel PCH: HDMI 0

  2021/10/02 09:54:21 Found ALSA device: hw:CARD=PCH,DEV=7 - HDA Intel PCH: HDMI 1

  2021/10/02 09:54:21 Found ALSA device: hw:CARD=PCH,DEV=8 - HDA Intel PCH: HDMI 2

  2021/10/02 09:54:21 Found ALSA device: hw:CARD=PCH,DEV=9 - HDA Intel PCH: HDMI 3

  2021/10/02 09:54:21 Found ALSA device: hw:CARD=PCH,DEV=10 - HDA Intel PCH: HDMI 4

  2021/10/02 09:54:21  network Audio IPv6 support disabled

  2021/10/02 09:54:21  discovery from

& 2021/10/02 09:54:21  discovered network audio: name='UsBridgeSig' version='Signalyst Network Audio Daemon 4.1.1'  @

& 2021/10/02 09:54:21  discovered network audio: name='UsBridgeSig' version='Signalyst Network Audio Daemon 4.1.1'  @

  2021/10/02 09:54:22  connect to [ipv4]

  2021/10/02 09:54:22  network endpoint: Qutest: USB Audio (hw:CARD=Qutest,DEV=0)

  2021/10/02 09:54:22  network endpoint: snd_allo_digione: Allo DigiOne HiFi wm8804-spdif-0 (hw:CARD=sndallodigione,DEV=0)

  2021/10/02 09:54:22 CUDA offload requested

  2021/10/02 09:54:22 ROCm/HIP offload requested

  2021/10/02 09:54:22 libDSP version 21.19.1

  2021/10/02 09:54:22 HQPlayer Engine version 4.43.2

  2021/10/02 09:54:22 CUDA offload: all

  2021/10/02 09:54:22 Number of processor cores: 4

  2021/10/02 09:54:22 Core mask: 0000000000000000000000000000000000000000000000000000000000001111

  2021/10/02 09:54:22 CPU brand name: GenuineIntel

  2021/10/02 09:54:22 Core pinning enabled

  2021/10/02 09:54:22 Initial parallel threads: 4

  2021/10/02 09:54:22 Number of logical cores: 4

  2021/10/02 09:54:22 DSP thread pools disabled

  2021/10/02 09:54:22 DSP pipelines disabled

  2021/10/02 09:54:22 Pipelined engine enabled

  2021/10/02 09:54:22 DirectSDM enabled

  2021/10/02 09:54:22 Audio engine: network

! 2021/10/02 09:54:22 clPlayerDaemon::CreateEngine(): clHQPlayerEngine::Initialize(): clString::ToUInt(): not an integer

% 2021/10/02 09:54:22 ...configuration reloaded

Looks like a corrupted configuration file in this case.

You can make a backup copy of working /etc/hqplayer/hqplayerd.xml just in case it happens again.

OP should change the title of this post as this isn’t a Roon issue. How does a config file get corrupted and what can be done to stop it happening again?

Thanks - good to know. I will take a backup. Thanks for the explanations.