Another stuck on adding music to database

Custom server running freenas 11.2 128gb memory, 48tb hard raidz2 (8x6tb) 2 intel e5 2650v2. Roonerver 1.6 build 416 installed on ubuntu running on a vm.

Gigabit network with NETGEAR PROSAFE JGS524.

using multiple custom built pcs running windows server 2019, and windows 10 running roon bridge

adding music stalls and blue circle keeps spinning

I know many have had issues like this and I have done and extensive searches on the support forum. It seems many have had the same issue for different reasons. I’ve been trying to troubleshoot this on my own for months and I’m finally ready to give up on solving this myself. This started after upgrading to 1.6 many months ago. At that time I had roonserver running flawlessly for installed in a docker container running on rancher installed in a vm on freenas. So these are the things I have tried.

I installed roonserver on two different windows computers pointing them to the same storage location on my nas.

After that I put together a small fanless server and installed rock onto that.(same result).

After that I started moving my music folders over to another folder about 10 at a time since I have over a terabyte of music and even down to the last few folders it was still doing the same thing.

The last thing I’ve tried was to completely destroy my database and start over, and even that didn’t work.

All of this was done months ago. Since then I created new shares, fiddled with permissions countless of times and yet nothing has fixed this. Currently I have the latest build running on ubuntu installed on a vm inside freenas 11.2.

Hi @orlando1,

Starting out, can you share a screenshot of Settings > Storage as well as a screenshot of the import screen when you click on the blue spinner?


Just to add, it’s the same whether I use my storage as a network folder or when I had roonserver installed directly on my windows 10 computer and had the nas mounted in windows 10 added as local storage to roonserver. It’s also the same having rock installed on a dedicated computer. In the past, I’ve had roonserver installed inside of a docker container and used rock server with the same nas drive and it ran flawlessly before the update to 1.6.

Did you ever try having the music local to the machine? RoonServer and the music all in one box, so to speak.

No. All of my pc only have a single solid state drive. Neither is large enough the hold my library. I think I have a spare 2tb drive laying around somewhere. That would be a lot of work though. But if needed I could take the time to do it.

I was just suggesting taking an external USB 3.0 Drive, load part of your music and try that as a quick test. Not go all the way and load another internal drive.
That way, the entire network, the NAS, etc is taken out of the equation. If it works, then you have a baseline to start adding things back.
And yes, an external 3.0 USB spinning disk hard drive is fast enough to serve music files to Roon. Have used one on a spare system for years without a glitch.

I was just telling you what I have. And I don’t want to go the route of having an external usb drive. That would require me to ditch my entire setup on freenas that was working for three years prior to the update. I would like to keep my current setup if possible. I just want to get it back working again like it was.

But I think I will go ahead and copy my library over to my spare drive and install rock on a spare build that I have just to rule out if it’s a glitch in one of my folders or something going on with my nas drive.

1 Like

So I remembered that I had plug in external enclosure. So that made it easy to copy my music folder over after plugging in the drive. So I installed roonserver on another machine with the drive connected locally and the same thing is still happening. No matter the drive or where I install roonserver, the adding music is stuck on 2641 with 0 added. This is out of over 17000 tracks. So around 15000 are added and it freezes at 2641.

Hi @orlando1,

I’d like to enable some diagnostics on your account so we can take a look at what you’re experiencing here. Before I do this, may I ask that you please do the following and make a note of the time you do each:

  • Reboot your Core machine.
  • Start up Roon and let the spinner go for ~5 minutes.
  • Reboot your Core machine once more.
  • Start up Roon and let the spinner go for another ~5 minutes.

This should allow the team to gain some insight into what you’re experiencing in the report. Once you’ve done this let me know the timestamps and I’ll enable diagnostics on your account. When the diagnostics report is uploaded I’ll send it over to our team for analysis.

Ok, thank you.

Ok, I’ve done this on the machine where I copied my music folder onto an external hard drive and installed roonserver where the storage is local removing the nas from the equation. The timestamp from the logs after both 5 minute intervals is 09/27 12:50:23, and the one after the first 5 minute interval is 09/27 12:45:37.

Hi @orlando1,

Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

Thank you. I have it back up and running now.

It’s been a few days now. Would you happen to have any updates?

It’s been almost two weeks. I’ve done everything that was asked of me. So I ask again. Are there any updates of my situation?

Hi @orlando1,

Apologies for the delay here. I requested an update from the team and confirmed that they were able to analyze the diagnostics report.

In the report, they found some problems with files in a certain path in your storage location. Moving the files in the following directory out of your watched folder and see if there is any change here?

E:\Music\Sonny Stitt\Sits in with the Oscar Peterson Trio (1959) (Bonus Track Version)


That was it!! Thank you so much for you assistance in this. I really appreciate it!

Hi @orlando1,

I’m glad that resolved things for you! Would you mind sending over those files so the team can take a closer look at why they were causing an issue? If you could, send them over to me in a private message using a shared Dropbox link and I’ll make sure they get to the team.