Any way to get WiFi working on my MOCK?

i just installed rock on my non-NUC fanless build and everything has gone as expected and quite smoothly so far.

quick question: how is wi-fi connectivity enabled / configured in rock? wi-fi is enabled in the BIOS, however, the networking tab in the web UI only has an ethernet tab.


if it doesn’t appear automatically on the web ui, it is not supported.

thanks - driver related?

no expectation of official support for this non-NUC build, however, interesting that all else seems to work fine except the wi-fi. anyway for me to get it going?

most modern wifi chips have half the driver in the OS, and the other half as binary firmware blobs loaded at boot up.

They can get big and require a lot of testing and maintenance, so I only included what’s needed for supporting the NUCs we have and test.

nope, the entire idea of ROCK is zero tweaking allowed.

ok - thanks for the explanation. i will connect to the LAN with ethernet.

fwiw: i was using wi-fi network connectivity as a form of optical isolation to remove all upstream electrical noise from the signal. just something to keep in mind re: wi-fi.

topology was: wi-fi > laptop > usb dac

I also have a problem to use wifi on my NUC8i5BEK
Ethernet works well, but I hope to use wifi.
Please check the wifi driver for NUC8i5BEK is working or not.

I think you’d be better implementing a Wifi extender with ethernet. Wifi in Linux always has a bit of user configuration and that configuration can vary depending on the chipset used. It would be one thing if you were connecting to an “open” network and could just select it but there are a significant number of ways that Wifi authentication can be implemented and exposing all of them for “wifi support” isn’t the most straightforward.

You could also run Roon Server under a full distro of Linux which would give you direct access to bringing up Wifi under that distro. This would also give you all the tools needed to troubleshoot Wifi if you encountered errors, drop-outs, etc.

Thanks. for your answer.
I’m using RospberryPi(linux) by wifi setting.
but I can’t find any way to set the wifi by telet, or something else for ROCK.
(I also tried open wifi, using my router, but there’s no connection)

I think that’s because of the absence of wifi driver on the ROCK image.

Do you have the ROCK web page open? You would set wifi there.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.