Any way to ignore "additional artists" in songs?

Hi there. I’ve been listening to a lot of Soundgarden recently. I was checking Roon’s Home page, and under my recent top artists there’s “Flower of Power Horns”, which I found is actually “Flower of Power” playing “horns” in 2 songs. Naturally, I don’t care about this artist being part of my recent to artist, since I just care about the main artist. These are local songs (local files)

I tried removing them from the credits, but I still see them in each song.

Is there any way to fix this for the future?

Tracks 4 and 9:

As far as I know, “Your top artists” are based on Play History. Not sure if removing that artist now will
change tracks played historically. You could test if this change will make a difference going forward in recording Top Artist playtime by playing those two tracks with the Flower of Power Horns and see if the time advances from 7 minutes.

If it does, then you can remove the Flower of Power horns, by removing those track plays in the History section.

but as you can see, I can’t even remove it. I’ve unchecked them in the credits page, but they still show in those songs :confused:

Well, you have to do it several times.

  1. Edit Album Edit Credits, uncheck them
  2. Edit each individual track, 3 dot menu, Edit Credits, uncheck them

And then they will be gone

See below as I just did it,

hmm this is rather confusing, why removing it from the album doesn’t remove it from all tracks? Anyway, thnaks for the tip

Hi @Dexter_prog,

Thank you for reaching out to us about this. It looks like @Rugby was able to point you in the right direction. In this case you had to make the correction for each instance where the credit annotation appeared. If Flower of Power had only been credited on the album level that would have sufficed.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.