Anyone have Roon and BluOS working flawlessly?

Bluesound Node 2i, Pulse flex, no issues, rock solid Roon connections.

… for what it’s worth.


Tidal or local library?
WiFi or Wired Ethernet?

Both, Tidal, Qobuz and local.
Wired (Node 2i) mixed WiFi/ wired Pulse flex.



my setup, that works fine at the moment:

  • Rock on NUC i7 quad (wired)
  • Qnap for local library (wired)
  • Bluesound Node 2 (wired, two network hubs) with external DAC and active speakers
  • Bluesound Puls 2 (wireless)
  • Bluesound Puls Mini (wired)
  • Switches Zyxel 1900 with multicast enabled
  • Access Points Meraki (exclusiv 2.4Ghz for Puls2)
  • Router OpnSense on Atom C2550
  • Sources: local library, Tidal, TuneIn Radio, DI.FM
  • Roon DSP: some settings for each Bluesound

Grouping setups:

  • all three Bluesounds by Roon - sometimes sync issues
  • all three Bluesounds by BluOS - no sync issues, but no individual Roon DSP possible. This setup I prefer for a day by day use.

In the past there are a lot of compatibility issues after updates of Roon or BluOS, when running grouping by Roon. The Bluesound devices reboots.

I’ve invested a lot of time in the network setup - changing cables, switches and access points. Bluesound devices are very sensible by wifi. You need an excellent signal quality (help - diagnostics) for a fine working with roon in CD quality.


Thank you, Ralf - very thorough. I’m glad everything is working well for you!

Thanks all! Sounds like some of you are working great and some of you are having glitches.

I have a few more days to decide if I’m going to return the Node or not. I’m leaning towards maybe doing that if only to play around with something different.

Roon is more important to me than Bluesound in this case. Hopefully NAD/Bluesound will work things out in the next BluOs update. They make nice affordable, well designed and readily accessible products. Fingers crossed.

Here’s a relevant topic for anyone possibly stumbling upon this one in the future.

Seems to me the problem is with Roon and its hypersensitivity to the network, not the Bluesound products. I had the drop out issues when using a PS Audio DirectStream Jr DAC and thought something was wrong with it. Then I got an NAD C658 and it was even worse. With the NAD, BluOS worked fine but Roon would cut out within 20 seconds or less of starting a song and the whole device would drop for about 10 seconds from the list of Roon players. Both the PS Audio and NAD were wired to a network switch. After tons of troubleshooting, I replaced the switch and haven’t had a single problem since. There’s nothing wrong with my old switch - every other device worked fine. And there’s nothing wrong with even the port on the switch that I was using since as I said, BluOS never had any streaming problems, only Roon did. But for whatever reason, Roon didn’t like that network switch. I replaced it over a week ago and have since streamed many hours of music with Roon without a single interruption.


I had the same problems with my Bluesound Node 2, connected hard wired. But I gave the core, Node a static IP. Problem solved!

I have a complex system with 5 endpoints, 3 of which use BluOS. All are connected with wired ethernet. Core: SGC SonicTransport i7.
I have a NAD C368, Powernode 2, and Pulse mint in 3 different rooms. 2 other rooms have other systems connected through micro or ultra Rendus. I have no latency, drops, skipping, or lags. Syncronization across the house is excellent.

I am having lags in playback and skipped tracks. When I start a new playlist, genre or Album, it stalls in the first track, then has to skip a track or two before it starts playing.

4 bluesound node 2is wireless connected via a mesh network to a Nucleus Core and a QNAP media library. I also use Tidal. Behavior is some regardless of source.

Had exactly the same problem (lags in playback and skipped tracks after pressing play). This was with Node 2i and Flex 2i (wireless but in line of sight to the router). Sync via Roon was always off. Outside Roon, the Node 2i would occasionally just disappear from the BluOS app. It would reappear after a few minutes - an hour. All this was back in Dec 2018 - Jan 2019. Not sure if subsequent firmware improved the situation.

What network switches did/are you using? Did you upgrade to new brand or model or just buy an new one of the same? Thanks in advance.

Originally I had “TrendNet 8-port Unmanaged Gigabit GREENnet Desktop Metal Switch, Ethernet Splitter, Fanless,16Gbps Switching Capacity, Plug & Play, Lifetime Protection, TEG-S80G”

Works fine as a switch but Roon doesn’t like it. I replaced it with this one:

“TP-Link 5 Port Gigabit Ethernet Network Switch | Ethernet Splitter | Sturdy Metal w/ Shielded Ports | Life Time Warranty| Plug-and-Play | Traffic Optimization | Unmanaged (TL-SG105)”

I have had the Node 2i for about 4 months, have not had 1 problem. Works perfect.

1 Like

In the past I have had sync issues with BluOS devices.
What seems to work for me is to set up endpoint groupings in BluOS, then do all controlling through Roon (or the buttons atop my Pulse Flex Mini). Once I group two devices in the BluOS app, only one device represents the group to Roon for selection (although both will play, and I can turn the Flex on/off separately with its physical buttons or with a physical remote control).

Had Node 2 for about a year. No issues, except not keeping sync when grouped with other RAAT points. That was fixed finally recently. Never had any issues with discovery or playback, in that regard it’s been rock solid.

I would say that I have a nearly flawless system using ROON with BluOS devices:

I use a Pulse Mini, Node2, and NAD C368 (as a preamp) on my main system.

I have 5 endpoints, and 3 are connected through BluOS hardware. I have had no problems at all unless I neglect to keep abreast of the software updates in tandem with he Roon updates. All of my endpoints are wired. I have not had syncing problems either, even between the BluOS and non-BluOS endpoints.

I have a NAD M10 (BluOS) on demo here at the moment. Grouped into a zone with a RPi running DietPi, I’m also getting some skipped tracks and dropouts.

I have 2 NAD CI-580s and 10 CI-720s connected via a Nucleus+ that have been running flawlessly since the multi zone sync issue was finally fixed a while ago. I have never had issues with drops or lost zones.