App on android rarely finds my innuos zenith

i have a bt router and an innuos zennith set as roon core yet my roon app on android connects about once out of 8 efforts while all other software for the zennith is instant,you give me just 14 days befor you take money not long enuff to solve i did have it on pc but it kept trying to find pc not zennith so i re installed app and removed pc software. please not only 14 days to help me or i have to pull out :((

Hey @stan_bell — Thank you for reaching out to us, and I apologize for the difficulties here.

So we can better understand what may be happening here, may I ask that you please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Additionally, so we can gain some greater insight into the behavior you’re reporting, please verify the following:

  • Just to clarify this, were you using the PC as a remote? Or did you set up a Core on the PC? Were you able to connect to the Zennith when using the PC as a remote?
  • Have you tried power cycling your Core machine, remote device, and networking hardware?
  • Do you have any other devices that you can temporarily use as a remote? Knowing if this connection issue is limited to one device or multiple will help pinpoint the root of this behavior.

Kind regards,

yes i had pc as a core but then realised the remote app was trying to connect to pc as a core so i reset everything removed pc software reset zennith and reinstalled android app which searches for core invain while zenith is as should be set as core

this is how it should be

oh and yes i was fine connecting when pc was set as remote,ill try an ipad with remote app

ok it instantly worked on ipad pro so clearly settings in android matter help

then i got android to scan actual ip address of zenith that didnt work

Are you certain that the Android device is on the same WiFi network? And not on a different subnetwork?

Hey @stan_bell,

So just to confirm, the Android device isn’t seeing the Zenith on the network at all? If you use an app like Fing you can scan the network and look at all connected devices. Can you try this with the Android device and confirm whether or not you see the Zenith?


well i should also say that all other apps on same android find the zen instantly, ill try that app link ta

oh and yes i have reinstalled roon app also

hi thanks,ok used feng and yes the zen is on the network fine orange squeeze finds instantly

useing ipadpro fine but dont want to use for this so regularly as will thrash battery hence need to use android thankyou

Hey @stan_bell,

Thank you for checking Fing for me and providing some additional details here. So we can get a better idea of your current setup, can you please describe your network topology? What networking hardware are you using? Knowing how everything is communicating can certainly help!

Based on the troubleshooting performed (Android can connect to PC Core, iOS device can connect to Innuos Core, Android can see Innuos Core on the network) it sounds like you may be experiencing an issue that we are currently investigating where some Android devices have trouble connecting to a Linux Core.

We have a survey they we are using to gather more information, and there are also some great troubleshooting steps here that can often help.


1 Like

sorry but i explained the same android connects fine when i use different apps to connect to the zen

ill struggle through survey asap but please note the android connects fine to the zen but NOT YOUR APP

Hey @stan_bell,

I wish to offer my sincere apologies for the difficulties you’re experiencing.

As mentioned above, based on the troubleshooting we’ve done thus far, it appears that what you’re experiencing is the same behavior we’ve been investigating regarding the some Android remotes having difficulties connecting to Linux Cores.

Before we can say for certain, we’d like to review the survey results, so please let me know when you’re all finished!


may need help with survey, been away so now roon payment taken anyway : (

will try asap really appreciate help but struggling to get to pc

Hey @stan_bell,

Is there anything specific about the survey you need help with? If you have any questions just let me know!