Apple Ear buds stopping roon

Does anybody else have a problem with air pod pros stopping Roon, sometimes it’s when I take them out of my ear and other times when I’m returning them to their case, I can also happen with my partners sony headphones are turned off.

@John_Burrow, assuming you are using your AirPod Pros with a Mac or iOS device, I believe this is how Apple configures their Bluetooth devices to interact with the playback system. My AirPods stop playing on Roon or iTunes Music on my iPhone as soon as I take them out of my ears. This is an Apple System design issue.

An annoying one. I have the same experience and have not found a way to disable it.

1 Like

AFAIK, this is considered a feature rather than a bug. The intent is that you can remove an AirPod, pausing your media playback, speak to another person while your media is paused, and replace the earbud, resuming media playback, all without interacting with your media playback controls. Not an issue for me, but I understand your annoyance.

1 Like

it’s a very frustrating, I can’t wander off into another room to take a phone call on the airpods, my partner hates the fact the music keeps stopping.

You can turn off this feature…

Turn off automatic ear detection

Your AirPods automatically stop playing audio when you take them off, and resume playback when you put them back on. You can change this setting.

  1. Wear your AirPods, and [make sure they’re connected to your device.
  2. Do one of the following:
  • On iPhone or iPad: Go to Settings, tap the name of your AirPods near the top of the screen, then turn Automatic Ear Detection on or off.
  • On Mac: Choose Apple menu > System Settings, click the name of your AirPods in the sidebar (you may need to scroll down), then turn “Automatic ear detection” on or off.

Just need to turn off automatic ear detection in the settings.

  1. Wear your AirPods, and [make sure they’re connected to your device.
  2. Do one of the following:
  • On iPhone or iPad: Go to Settings, tap the name of your AirPods near the top of the screen, then turn Automatic Ear Detection on or off.
  • On Mac: Choose Apple menu > System Settings, click the name of your AirPods in the sidebar (you may need to scroll down), then turn “Automatic ear detection” on or off.
1 Like

You should seriously consider a “better” endpoint than an AirPlay device, for many reasons…

Thanks you very much Ed, that worked.

If I have just Roon remote open on my MacBoob Pro and use my BT headset for work calls it also stops Roon from playing when I turn it off. The Mac isn’t my server just a remote so it really shouldn’t stop it. I guess it’s a MacOS thing but it does get a bit annoying given the stream isn’t touching the Mac at all.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.