Apple SuperDrive 'not ready' for ripping CDs

Today I connected an Apple SuperDrive to my Intel NUC8 but it won’t be recognized in RoonOS. Web Interface shows always ‘CD Ripper not ready’ … I tried several reboots and connecting the drive to different USB ports. Nothing changed. Any thoughts? Thanks.

That message is telling you that there is no attached storage available for the Superdrive to rip to - it’s not the Superdrive that’s the problem, but the lack of suitable storage.

Do you have internal storage or a USB drive attached to your NUC? NAS is not supported, as the KB article states:

Roon OS will automatically place your successfully ripped CD’s flies into connected storage (internally or USB connected). NAS storage is not supported. If you need to rip to a NAS, we suggest adding a small FAT32 formatted USB flash drive (16GB or higher would be fine), and Roon OS will rip to that. Then you can manually move those files to your NAS.


Hello @Steffen_Kast, and thanks for your report! Geoff has the right answer here, please let me know if you have further questions!

Thanks, Geoff. You have been right. Obviously, I ignored the storage part completely :roll_eyes:
Now it works properly.

Glad you’ve got it sorted :+1:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.