Apple tv code lost and cant reconnect

hello friends
I forgot the code to enable my apple tv any help plz.
Actually i did not forget the password its just after last update wont let me connect
to my Apple TV…how do i reset my connection from Roon to my Apple TV?

Hi @shlomo_reichani,

What happens when you enter the code? Do you receive any errors? Can you share a screenshot?

Hello Dylan
Thanks for reaching out, I know for fact that first time when I have been
asked to put Code I put the same one as I am trying now and it won’t
let me in to my AppleTV.
Here is what I get :

Add images

Hi @shlomo_reichani,

Are there any special characters in your password? If you change your password to something else (just alphanumeric) and try again is there any change?

Hi again
I have tried all kind of possible codes or passwords In which I can use and none of them worked. There for I put an easy code…
I really am not sure why that happened…

Hello @shlomo_reichani, are you able to disable this zone and reenable it? Are you having any issues connecting to other airplay endpoints?

Hello nunwiry
The AppleTV section is on the Roon Tested !
My Airplay is working fine on all other devices yes …
I can’t understand why Roon won’t accept my Code in which I
always connected to my AppleTV.

Hello @shlomo_reichani, could you please try to enter the password one more time then reply here with a timestamp (the date and time you encounter the issue) so I can enable diagnostics for your account?

Hi there
Well I hope I understand you correctly…I have tried to log in to my Apple TV today January 6 at 21:07 my time Israel time…
I hope that what you asked me to do…
Please note that my Apple TV turned on when ever I try to log in thru
Roon Tested category.

Hello @shlomo_reichani, and thanks for the timestamp! I’m enabling diagnostics on your account now and will let you know when the report comes in and I’ve passed it over to the QA team.

Many thanks appreciate it.

Hello @shlomo_reichani, I spoke to the device team, and at this time we have a good number of users working without issue with their Apple TV. With that being said, on the Apple TV, if you go to Settings > AirPlay and click on Airplay Everyone, you will see Security below. This might show Require Code First Time Only but should be changed to a Password. This can become an issue if you’ve rebooted or factory reset the TV recently, and is worth a try!

I have not reset my Apple TV to factory setting…So this is not the case.

Hello @shlomo_reichani, any luck following the previous steps? Let me know!

NO so far nothing works !

I’m not sure if this will help you, but I had a similar problem. It wasn’t looking for the password that I had setup, but just a 4-digit pairing code. Since I was just trying to listen to music, I didn’t turn on the TV. This was my mistake. With the TV on, and displaying the AppleTV, when I tried to pair, a 4-digit code came up on the TV just as the Roon app was asking for the code. I also found that after an incorrect response, it would change. After you type in a wrong code, make sure you wait several seconds for the code to update before trying again.
I’m not sure if this is the same problem you’re having, but I hope it helps.

Hello Thad
Many thanks for your help and an option that might work…I will sure try it and let you and all community here know if it worked for me as well…

Unfortunately it did not solve my issue…i have tried to put the new codes that appear on my
Apple TV but none of the codes fit and I still get same Error message…

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.