Apple TV is Getting Dropped and Not Reconnecting Since Latest Roon Update

Roon Server Machine

iMac, 3.1 GHz 6-Core Intel i5, 40GB RAM

Networking Gear & Setup Details

Linksys WiFi Raspberry Pi 4, 4GB
Apple TV
Airport Express

Connected Audio Devices

Cambridge Audio CXA81 via USB to the Raspberry Pi
Cambridge AudioMagic 200 via Apple TV
Libratone Zipp

Number of Tracks in Library

~20,000

Description of Issue

Since the latest Roon update, my Apple TV is periodically getting disconnected when not in use, and then Roon shows it as offline until I quit out of Roon and restart it. The device is discoverable and shows up continuously without any issues with applications other than Roon. Nothing else in my system has changed in any way since the update. And the other Airplay device I’m using (Airport Express) is not encountering the same issue.

Can you please let me know if you have any ideas about how I can troubleshoot or if this is a known bug?

@kd007, judging from your description of your equipment, is your Apple TV and older version with an optical output? If so, what version is it and what OS is it running, as well as what is your MacOS running? Also, how are both your Mac and Apple TV connected to your network, via Ethernet cable or WiFi?

@Robert_F Thanks for the quick reply. I’m using an Apple TV (3rd generation) and am using the optical output. The OS on my Mac running the Roon server is the most current (Sonoma 14.2.1) and the Apple TV is on 7.9 (the most current available for this generation of the Apple TV). The Apple TV is connected to the network via WiFi.

I am wondering if the WiFi connection is not very strong (or consistently strong) to your Apple TV. Roon requires a fairly robust network connection across devices, and depending on your environment (metal, other WiFi connections, neighborhood WiFi interference, etc.), the Apple TV may not be seen by the Roon Server consistently.

Is it possible to try to connect an Ethernet cable to your Apple TV (even by removing it from it’s current location) and see if your Roon Server connection issues are reduced or eliminated? This would eliminate one variable, or demonstrate that it may be a WiFi issue. The version of WiFi used on that model of Apple TV is fairly old and may not handle lower quality connections as well as some new devices.

1 Like

@Robert_F Thanks for the suggestion, but I don’t think it’s a week connection issue. I’ve been using the same device in the same spot for years without any problems. It’s well within range of the router (shows full bars and is only few feet away from the router), and all my other applications see it and connect to it without a hitch. It’s also not having any problems with Roon when it is recognized (no dropouts or issues). The problem is that when it’s not playing, Roon disconnects from it at some point and no longer sees it on the network even though it’s there.

Do you have a sleep timer set on the Apple TV to automatically turn it off after a set period of inactivity?

1 Like

No, there is no sleep timer set.

Hi @kd007,

Thank you for your post.

What is the make and model of your router? If it’s a dual-band router, which band are you using?

If it can be accomplished with minimal reconfiguration of your topology or setup, it’s worth trying this test. Removing WiFi allows us to reduce the variables involved and any data from this A/B test is illuminatory.

A few possibilities based on the symptoms:

  1. The router is mishandling multicast DNS for this Apple TV, causing device announcements to miss RoonServer.
  2. RoonServer or MacOS is rejecting the multicast DNS announcement from the TV.

The first explanation accounts for the vast majority of cases, particularly for Apple TVs in this generation (3rd generation, 2013).

The more detail you can provide about your network topology, the better. In the meantime, we’ve activated diagnostics and your RoonServer instance should generate an automatic diagnostic report for our servers when you next open Roon. We’ll follow up from there.

1 Like

Hi @connor,

Thanks for your help with this, and the helpful explanation of the possible issues based on symptoms. I’m using two Linksys Velop AX4200 WiFi 6 Mesh routers. I have the settings set so that the router will automatically use 2.5GHz or 5GHz based on the device connecting to it. I’ll see if I can get an ethernet cable connected as you and @Robert_F suggested.

@kd007, if an Ethernet cable connection option is not available, can you try to separate the WiFi bands and have the Apple TV connect only to the 5 GHz band?

@Robert_F and @connor, I haven’t been able to replicate this problem since shortly after I posted this a little over a week ago. Everything seems to be working fine again on my end.

@kd007, I marked this as solved based on your update. If this happens again and this topic is closed, please post in a new topic and reference these posts.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.