Apple TV no sound at all

Did you see my post…only solution I have found is to choose “System Output on the Core Machine you are hosting”…presume you are hosting Roon on a Mac? If so, then go to the sound setting on the Mac, and choose Apple TV.

I managed to upgrade mac hosting Roon to macOS Catalina and Apple TV to tvOS 13 before reading issues related to Roon. Got the audio streaming temporarily working using following workaround:

Set System Preferences > Audio > Output to AirPlay device:

then set Roon to use following device:

I hope the Roon no-sound fix for tvOS 13 comes out sooner rather than later since average user cannot easily downgrade to tvOS 12

Martin

Yes, this is not a solution. I have Apple TV 4K’s and they cannot do a downgrade. I never thought this would be an issue to stream Roon. Everything works but Roon on ATV.

Setup:
4 Apple TV 4K’s
Synology 2415+ NAS w/Roon Server
Netgear AX11000 12 stream WiFi 6 Router 2019

Info:
I get everything to show up, key in passcodes and hit play and ATV just sits there. I have 2 ATV’s hard connected and 2 wireless, symptom is the same for all. Tried everything, take down Roon bring back up, reboot Synology NAS, reboot router, reboot internet, reboot dog, reboot cat.

Please find a fix soon Roon Devs… I would encourage you to upgrade the importance of this to critical since more people are using devices like this.

Thanks again for such a wonderful support community. I love Roon!

Best,

Tom

Dear All,

I just updated tvOS 13.2 (17K5068b), now Roon is back to work.

Hopefully it is gonna work for all of you as well.

Have a great evening.

Sante

1 Like

Thanks for letting us know. Working for me here too with the 13.2 update. Now trig to get off the beta bandwagon…

Hello All,

We are cautiously optimistic that this issue has been resolved in the tvOS 13.2 beta, as a few other users have reported.

To provide some insight into what’s going on here: Our technical investigation concluded that Apple broke AirPlay playback from all non-iOS sources in the initial tvOS 13 release. iTunes playback worked correctly when playing to a single AppleTV zone, however grouped zone playback would fail on the AppleTV whenever non-AirPlay 2 devices were added to the group. Other applications like Airfoil are similarly affected.

-John

4 Likes

Can’t get Roon to play via Apple TV thru my home theater system. Latest ATV/Latest IOS/Nucleus.
Can choose the Zone, it shows it’s playing music on the Roon Controller on iphone but I hear nothing. I disabled and reenabled with the password shown on ATV and still nothing. Spotify/Tidal/and iTunes Music that is downloaded on my phone all play fine. What gives? Any help appreciated. Thanks!

Hi James,

I’ve moved your post here. Check out the thread. It’s been resolved with tvOS 13.2 beta.

Check out John’s post above.

Cheers, Greg

Thanks Greg but kinda confused as he says ''group zone" fails and I don’t have it in a group. Also, does this mean we have to wait until 13.2 update then it should work? Thanks!

Hi James,

Don’t worry about the grouped issue, your situation can be fixed by going to tvOS 13.2 beta. You could also just wait until Apple releases the stable 13.2 version.

You can (temporarily) join the Apple beta for the tvOS 13.2. That’s what I did.

Edit: It looks like you need to enroll in the beta program on Apple’s website first in order to participate. I did so a while back and forgot the procedure.

On the Apple TV, go to Settings > System > Software Updates. Click Get Beta Updates to On. Then click Update Software.

It should update you to tvOS 13.2. You can the go back to Get Beta Updates and set it to Off again.

That should solve the issue.

Cheers, Greg

Just an FYI, my (US) TVOS is on 13.0, is deemed by Apple to be up to date, and does not offer a beta OS version (to be exact, no line that says " Set Beta Updates to ON").

Must have cancelled the beta version.

Hi John,

It looks like you have to enroll in the beta software program on Apple’s website first. I did it so long ago I forgot the procedure.

Since I did in the past and that’s why it shows for me.

Cheers, Greg

2 Likes

ok thanks guys. think i’ll wait until it’s released. I was in the beta program once and it was a hassle.

Thanks for all this, I kind of assumed it was an update as non-Apple outputs still working fine. Have done 13.2 on HD and it’s fine. Presumably it’ll be good on the previous one (the last one with an optical out, annoyingly!). But I’m turning off Beta updates again afterwards (or will turn off automatic updates maybe), or I might get a(nother) dud one without knowing.

I’ll let 4k do itself when the full release comes out.

Waste of a couple of hours I really could have done without today!

And I find Apple TV fine by the way for non-critical applications like my workroom and dead cheap compared to ‘proper’ bits of kit. Ebay ones even cheaper.

Thanks for the clarification. I will be using native Tidal app on Apple TV until iOS 13.2 is released, seems more reliable than the other workaround I posted above

Apple TV just offered tvOS 13.2 update after manual update check and Roon is back in business with airplay streaming :slightly_smiling_face: :notes:

Hi @mlp - Thanks for letting us know!

@Sante_Roon/@James_Cortez/@John_Best - Can you please check to see if the update is available on your end and if this resolves the issue?

Dear @noris,

As said in my previous reply (34), around 2 weeks ago, already solved!

Many thanks to everybody.

Sante

1 Like

Hello,

Since 13.2 is available today for the public, yes it has fixed this issue. Thank Goodness!

Roon in my home is back baby lol…

Tom

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.