Apple TV won’t play via airplay but shows live and that it is playing

I have an Apple TV been through the set password and done that and it shows up and shows it’s playing except no sound :face_with_raised_eyebrow: it works fine directly from my iPhone via AirPlay, it plays from the Tidal app. This used to work fine. My core used to be on a Mac but is now on Linux. My blue sound node and iFi Zen both play fine … any ideas??

Is your volume set properly within Roon when you set the Apple TV as an endpoint? Can you post a screenshot of what you are seing from within Roon when you are playing to your Apple TV?

It all looks correct to me but still no sound. The Apple TV is hard wired

I also have the Apple TV Roon remote app - it says it’s playing but again no sound?



O

OK so I have to conclude this is a bug … basically if you put in airplay password etc as recommended it works. But if you stop a track and restart it looks like it works but no sound… if you go to Apple TV and toggle Airplay on/off it then works again… there’s something in the passing of the Airplay password from Roon that’s not working as it should - guessing it’s linked to the fact you now have to put an airplay password in which you didn’t before - on TVOS 16:1 will try update to 16:02 and see if it improves

That is a behavior I have not seen with my Apple TVs. I have run Apple tvOS 16.0x, 16.1, and now 16.2 without any issues on volume, etc. In your second screenshot showing the list of available endpoints, when you select the speaker icon on the bottom right next to the couch icon, what volume level is showing? I also have noticed a volume mismatch on my TV that needed an increase to support the volume levels being fed by Roon.

Shed Apple TV (same set up) - now moved to TVos16.2 and seems to have fixed it on both Apple TV’s. In both cases the TV isn’t used for sound the Apple TV’s are connected to AV amps and 7.1 systems

Glad to hear tvOS 16.2 seems to have resolved your issue.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.