ARC App not accessing Roon Core - Linksys EA9500/Orange Livebox v4

Roon Core Machine

V2.0 build 1128

Networking Gear & Setup Details

Roon server in located in sub network linked to a Linksys EA9500 router, which is linked to a Orange Livebox v4.
Port forwarding was done at both levels and the listening port was not modified from Server to internet. UPnP is activated everywhere too.
VPN Disconnected

Description of Issue

Hi,
I have an issue with Roon ARC App.
Roon seems to have successfully configured ARC on my PC application (confirmed to be securely accessible by Roon ARC).
When I turned to my phone with the Roon ARC App, it worked properly when connected to my home wifi
But as soon as I switch to GSM (5G) it seems to be unable to reach my Roon core anymore.
Any idea what I should try ?
Thanks
J

1 Like

Hi @Jack_Whis,

Thank you for the report and we’re sorry to hear that you’ve encountered a port forwarding snag. It’s likely that the culprit is an additional NAT layer that has somehow evaded the port forwarding rules in place.

Would you mind elaborating on the following?

First, are you seeing any error messages displayed within ARC on 5G?

Is the Orange Livebox v4 in Bridge mode?

I also recommend disabling IPv6, to test whether or not that’s interfering with the UPnP/NATPnP discovery.

Who is your ISP? We’ll want to verify if there’s carrier-grade NAT involved, as well.

We’ll be standing by for your response.

5 posts were split to a new topic: Opening ports on Experia V10a router

Hey, thanks for the follow up.
Please find my answers hereafter :

First, are you seeing any error messages displayed within ARC on 5G?
Yes
“Core Roon unreachable”
“Impossible to connect to your Roon server, please check your Roon Core and retry”

Is the Orange Livebox v4 in Bridge mode?
No, the Linksys is operating an independant sub network.
But my double port forwarding should work correctly even in that situation, the Roon software is able to connect ARC, and I successfully use that same double port forwarding with Plex.

I also recommend disabling IPv6, to test whether or not that’s interfering with the UPnP/NATPnP discovery.
IPv6 was disabled, no change : PC Roon soft is still able to access Roon ARC, and Arc App cannot connect to the core.

Who is your ISP? We’ll want to verify if there’s carrier-grade NAT involved, as well.
My ISP is Orange FR. Not sure if they use additional NAT.

Hi @Jack_Whis ,

Are you able to temporarily connect your Roon core directly to the first router in the chain to confirm if that works as expected? Connecting to the first router in the chain can give us some clues if this is a multiple NAT issue or something internal about the setup.