ARC Build 230 & Build 1362: Cannot remove album from library that was added through ARC (resolved by reboot, but weird)

I was testing an issue that occurs when only adding one track to the library in Roon, and then only this track is visible in ARC, as discussed here:

For testing this, I added one track from this album to the library:

Then the issue occurred (only this one track visible in the track list of the album in ARC) and I tried the workaround of clicking the (+) button in ARC, to add the whole album to the library - which it did.

But now I can’t remove the album anymore. Clicking “remove from library” in Roon does not bring up the “this album was deleted” message and it stays in the “Added” list:

What’s even worse, every time I tried, it seems that another version was actually added, so now I have 4 versions of this album in the library:

Whatever I do, e.g., …

I get this …

but nothing changes:

In ARC, it does not appear in the “Added” list because the whole list is not there, as reported in the general feedback thread.

And ARC shows only one version, and that one shows as NOT in the library:

Aha, I rebooted the ROCK and this made it finally disappear from “Added”:

And the album now shows only one version:

FWIW, I’ve seen issues recently with Roon needing to be restarted to finalize the removal when local content is removed (which has only happened when I’ve run experiments for these forums!). IOW, a Library cleanup doesn’t do the whole trick…

@andrew.v, I wonder if that’s related to the ticket you created but then could not reproduce – ROON-7940. I think it’s worth revisiting.

Thanks, @Suedkiez and @DDPS for highlighting this!


Ivan