ARC can not connect to Roon Server, unreachable, poor connection etc. [Ticket in]

Roon ARC all of a sudden won’t connect to my Roon server on cellular data, via WiFi on local network it connects fine.

Roon - Settings - ARC says; " Roon ARC can securely access your Roon server" and “Your Roon server was automatically cofigured and has been confirmed to be securely accessible by Roon ARC”!!! So Roon port forwarding is setup correctly.

So why won’t ARC connect? Read numerous posts here but unfortunately the correct solution is nowhere to be found.

Did several re-installs of ARC app, core resets etc…

Getting following messages:

  • Audio core only available on your network
  • Your Roon server isn’t configured for access outside of your network
  • Poor Connection
  • Can’t connect to your Roon server
  • Roon server unreachable

Btw, my network works fine

Streaming music through my Naim app via Qobuz works flawlessly!

1 Like

Hi, @Robert_Kuijs, thank you for your report. Could you, please, tell me when was the last time you saw the app working properly? Have there been any changes applied to your network setup recently? I am going to request the diagnostics report from your device and examine them.

Thanks!


Ivan

Hi Ivan, thanks for your reply. The last time it worked properly was approx. 3-4 weeks ago. Got me thinking when you asked about any network changes; I have a new modem/router from my internet provider KPN (Netherlands) since november 19. I have set up port forwarding properly (55000) and Roon says " Roon ARC can securely access your Roon server". I also have problems with long pauses (up to 20 sec.) between tracks (both albums and playlists). I know i have to make another post for that but are these issues maybe related to each other?




Got it, thank you! I examined your diagnostics report and it looks like there is an issue with the IP address which says the following: FormatException: Illegal IPv6 address, an IPv6 part can only contain a maximum of 4 hex digits (at character 10). It appears each time your Roon ARC app tries to access the Core. Also, on the Core side there are some strange port testing errors.

That said, it’s not likely to be an issue with the current Early Access but I will discuss this issue with our dev team when they are back later this week to see what the problem is

Thanks!


Ivan

Thanks for your help so far Ivan! Hope your colleagues can help out to solve it. Merry Christmas to you and your team!

1 Like

Hi @ivan, just curious if you have an update maybe?

Hi, @Robert_Kuijs, the possible problem is that your RoonServer incorrectly sends the IPv6 address. It’s not clear why does this happen but the error state is clear and I sent a ticket to the dev team.

Thanks!


Ivan

A post was split to a new topic: Roon ARC Won’t Connect

First my issue was split into a new support request by @Geoff_Coupe. He said “I’ve moved your post from an existing Support request into a Support request of its own, so that the Support team can better diagnose your issue”. I already had to answer several questions there, but never got an answer!

That new service request topic is already closed now. And now what? “back to the old topic”? Is this because i’m on the Early Access branch according to @Geoff_Coupe?

Right now, very annoying and unclear to me as a customer.

I started this topic 25 days ago!!

Can somebody at Roon pls help me out?

Excuse me, but I moved a post from @PETER_GARAFOLA from this post thread into a topic thread of it’s own. It wasn’t a post of yours that I moved.

Maybe there is confusion because of this post, where Connor referred to @Robert_Kuijs‘s existing thread here in EA, i.e. this present one where we are now:

I too have this problem, at times album images will be displayed but will not play. Playing at home over WiFi is absolutely fine, help!!

I have reinstalled the ARC app but still it will not work. The port seems ok on the modem and ARC says it is communicating with the modem ok. Everything is fine over WIFI, but even with 5G I get the Roon server unreachable. Any ideas please.

Hi All,
Hi @Robert_Kuijs, hi @Rob_Higginson

Exact same issue from today, with a new internet box (router) from LOL here in Luxembourg!!
Did you get a feedback from Roon?
Thanks for that!

Hi Pierre, my problem was that my internet provider decided not to allow port forwarding for me any more.

Hi Rob, thanks for your quick feedback! Mine allows me!…
Short question that might help me solving : does ARC need an open port or a redirected port (forwarded)?
(Sorry not an expert…).
Thanks again! Kind regards.

Good morning Pierre, the software tried to open up a port, which on my router was a problem. I think I had to setup the port myself. When you test ARC it should tell you if the port is designated ok. If not on my router I, as I said, designated the port. I have to say I’m no expert. Good luck if I can help anymore please feel free.

1 Like