ARC can not use

{
“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“116.aaa.bbb.ccc”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.1.1”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">501ActionFailed</s:Fault></s:Body></s:Envelope>”}
}

I have used roon ARC for few months.
I can not use it,now.
I checked port fwording and Upnp settings.
Please help me resolve this issue.
Thank you
Have a great day


Welcome to the community.

If I interpret your screenshots correctly, it appears that you have enable BOTH port forwarding and UPnP. I believe it should be sufficient to enable either on or the other as having both enable can sometimes cause conflicts.

Hi:

Thanks for your reply.

I have tried to turn off port forwarding or Upnp. The problem is the same.
Please ref below message.

Have a great day

Upnp off

{

“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},

“external_ip”: {“actual_external_ip”:“116.aaa.bbb.ccc”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},

“natpmp_autoconfig”: {“status”:“NotFound”},

“upnp_autoconfig”: {“server_ip”:“192.168.1.1”,“found_upnp”:true,“error”:“doaction request return statuscode: UnknownError”}

}

Blockquote
Upnp off
{
“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“116.aaa.bbb.ccc”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.1.1”,“found_upnp”:true,“error”:“doaction request return statuscode: UnknownError”}
}

port forwarding off
{
“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“116.aaa.bbb.ccc”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.1.1”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">501ActionFailed</s:Fault></s:Body></s:Envelope>”}
}

Just a Roon user here…

Out of curiosity, what is your Cores IP address?

IP addt is 192.168.1.2

Hey @Teli_Wu,

The error above is saying that another program or app is using the same port that Roon is trying to use. The most common culprits are gaming setups that have already enabled port forwarding, routers that have reserved certain port ranges for their own processes, or a second Roon Core on the same network.

  1. Try finding and closing those programs using the same port.

  2. Try changing the port connection settings for Roon by adding 1 to the previous port setting. For example, change the port from Port: 55000 to Port: 55001.

Let me know if the above help! :+1:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.