ARC cannot connect to the core - Need assistance with Mikrotik configuration

Roon Core Machine

Roon Core information:
54-B2-03-F7-01-4B
192.168.88.245 core IP
No HDD connected
Intel NUC i3 (Nucleus rev. B)

Networking Gear & Setup Details

Network is based on broadband 5G router (MikroTik)
I have room remote on Android smartphone (Sony Xperia 5 III) and iPad Mini (latest version).

  1. Who is your internet service provider? Orange Poland

  2. Please list the make and model of your modem and router? MikroTik Chateau 5G ax

  3. Do you have any additional network hardware, like additional routers or managed switches? No

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?
    Basic default setup

Connected Audio Devices

AVM CS6.3 to network by ethernet.

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

{
“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“37.aaa.fff.ggg”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
}

My core cannot access/connect to Roon ARC. It happens with different ports. UPnP enabled.

Welcome to the community

This seems to suggest that UPnP is not enabled or working correctly.
Perhaps you can try manually configuring port forwarding?

Would it help if I had external IP address? Or it doesn’t affect this situation?

If you are asking if there is a requirement for your Roon core to have an external ip address this should not be necessary. Your Microtik has an external ip address. A port forwarding rule will ensure that traffic coming from the internet on the designated port is correctly routed the internal ip address specified by the port forwarding rule.

Have you checked your router settings?
I’m not familiar with Mikrotik, but a quick glance at the manual seems to suggest that enabling UPnP is a two-step process. First you need to enable the UPnP feature, then you have to add interfaces. Was this done correctly?

Thanks SvenM for your reply.
I tried to connect ARC with nucleus core several times using different routes (including AVM router) as well.
I asked for external IP address as my IT guy has suggested this may be an issue.
I will double check UPnP setup with him and come back to you accordingly.

I am just curious which interface should I add. Can you advise, please.

As I mentioned I’m not familiar with Mikrotik routers. I can only speculate that you need to add an external interface as well as the internal interface to which your NUC is connected.

I’ve taken the liberty of adapting the title of your post so that perhaps someone with Mikrotik knowledge can help you.

Hi Sven,

after adopting some changes (e.g. disabling firewall, also roon system update) I found following message:

{
“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“37.aaa.bbb.ccc”,“actual_external_ipv6”:“null”,“router_external_ip”:“10.227.43.6”},
“status”: “status”: MultipleNatFound
,
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.88.1”,“found_upnp”:true}
}

Looks different. Please advise.

The error message now indicate multiple NAT. This is typically the result of having more then one router one after the other. Is this the case is your setup? Is your Mikrotik connected to a router that is provided by your ISP?
The article linked in one of my previous posts provide more information on multiple NAT.

Not sure we’re you disabled the firewall. If this is on your router, this is generally not a recommended approach.

No, I have only one router. It is confusing.

What about LAN and WAN Interface list. Should it be static? There is also none, dynamic and all options.

Hi @Andrzej_Wranka,

The diagnostics you’ve provided suggest there is a redundant layer of network address translation preventing port forwarding.

This can either be at the local-network level (commonly as a result of two routers), or at the level of your service provider (in the form of carrier-grade NAT).

Based on a few articles I’ve found, it’s Orange Poland, your service provider, that is responsible for the double-NAT layer here. They have implemented carrier-grade NAT on your account - it’s worth reaching out to them to ask the following:

  • Have you implemented carrier-grade NAT for my account level?
  • Have you fully implemented IPv6, or do you have IPv4 addresses available?
  • Can I request a static IPv4 address to support port forwarding?
  • Are there any ports you have reserved at the ISP level I should be aware of?

In the meantime, I’d check out VPN alternatives in #tinkering until they respond if you’re eager to use ARC on the go. Thanks!

Than you Connor for your advice. I will try to teach them out or consult my IT guy as it seems quite complex.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.