ARC can't connect to my Core anymore

Continuing the discussion from ARC can't connect to my Core:

First my ARC could not contact my Core (MacBook Pro M1). Then, an expert from my internet service provider (Elisa, Finland) worked some 30 minutes (=77 euros!) to make the connection work. I do not know what he did, since I am not an IT professional. Also the guidelines on Roon’s webpage are such technical jargon that I could not understand them.

Unfortunately, after a few months the ARC stopped connecting again. When opening the app, first a blue line is moving over the track image. Then Roon says: ”Poor connection. Try again. Retry.” I am sitting next to the Mac serving as the Roon Core, and earlier the connection has been ok. The Mac and the iPhone are both well connected to the same WLAN home network.

In the MacBook, I get the following message:

{
"connectivity": {"status":"NetworkError","status_code":502,"error":"error: Error: connect ECONNREFUSED 46.aaa.bbb.ccc:50000, response code: undefined, body: undefined"},
"external_ip": {"actual_external_ip":"46.aaa.bbb.ccc","router_external_ip":"null"},
"natpmp_autoconfig": {"status":"NotFound"},
"upnp_autoconfig": {"status":"NotFound"}
}

Welcome to the Roon community forum, @Lauri_Thuren.

The diagnostics you’ve provided suggest that UPnP is not properly configured on your router.

Please first try the following steps:

  • Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Check if your modem is in Bridge mode

If you continue to experience difficulties, please tag the support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

I tried to follow the steps, managed to open the settings of my Huawei Router and the Roon settings. Unfortunately, as I am not an IT professional, I find some information only (below), but cannot solve the problem.

Please first try the following steps:

· Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core UPnP is on. NAT is on, not symmetric but cone

· Try to manually open the port in your router’s port forwarding configuration No static IP-ports
**Mobile WAN IP (connected, ***)

· Make sure the IP/Port (where?) matches the Port listed in Roon → Settings → ARC Roon Core ip, port 50000

· Check for any VPNs or Firewalls that might be interfering VPN is off

· Check if your modem is in Bridge mode No Bridge Mode

If you continue to experience difficulties, please tag the support team and include the following information:

  1. What is the make and model of your modem and router? deco_m5 // Huawei N5368X

  2. Do you have any additional network hardware, like additional routers or managed switches? No

  3. Who is your internet service provider and what is your geographic region? Elisa, Finland

Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both? No Bridge Mode

Still waiting for an answer.

Hi @Lauri_Thuren
just another user here trying to help.
Something very simple to start with, but maybe that will help:
Have you already powered down your mobile Huawei router and then restarted your entire network with a reboot of your Roon core machine?
If that doesn’t help, please delete and reinstall the ARC app on your phone.
Followed by a reboot of your Huawei router, your Wifi router and all network components, your core and a reboot of your phone.

It looks like you have two routers, and therefore, two subnets. You’ll need to manually forward port 55000 from the Huawei to the Deco, and if UPnP doesn’t work on the Deco, forward 55000 from Deco to Roon core.

1 Like

Hi @Lauri_Thuren,

Did you have a chance to review our moderator @Martin_Webster’s comment above? Thank you for your patience as the tech support team worked through the queue. If you’re still experiencing an issue with port forwarding, we’re standing by for your response to review diagnostics and assist you further.