ARC: Closed-Loop VPN Mesh with NordVPN for Port Forwarding Workaround

Hello, I have issues with ARC as per below data.
This is the diaggnostics data:
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“185.x.x.x.x”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
(IP maked)
I am using a 4G Router from Alcatel, as non 4G internet in Lebanon sucks. Device name HUB71. I have enabled UpnP from the setings of the router. Roon Core is installed on a MacMini.
When on the same network Roon ARC on my mobile can obviously see the core.
Any Help appreciated.

Your mobile network provider will need to give you a public IP address (either static or dynamic) for ARC to work. Can you check with them whether they are doing this?

It is highly likely that your network provider is using Carrier-grade NAT which is typical with 4g providers. You can see that if you can compare your public IP with your WAN IP (on the info page of your router). If both don’t match, your ISP uses CGN and it’s probably why you won’t be able to use ARC as long as you don’t have a dedicated public IP.

I have noticed that i had Nord VPN running when i copied the error message. I am sorry for that. When i disabled VPN this is the Error i got.
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“xxxx”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.x.x.x”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="\” s:encodingStyle="\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">501ActionFailed</s:Fault></s:Body></s:Envelope>”}
I tried also to configure Port forwarding and i set it to the Roon Core IP mentioned on the Roon ARC setting tab but it didn’t work. So is it still a Static IP problem?

Most likely, if you are using a 4G router. Check with your mobile network provider whether they can provide you with a public IP address.

I doubt that very much. Anyway i also noticed that without the VPN my Tidal and Qobuz subscriptions won’t work because they are registered in France and Lebanon is not supported by those 2 services. So unless there is a diabolic turnaround i won’t be able to use ARC excpet at home :smirk:.

A post was merged into an existing topic: ARC security concerns

Hi @Peter_Sabbagh,

As a workaround, you could configure NordVPN itself as a pathway for the Core to reach ARC, in place of port forwarding. While this isn’t an officially supported means of streaming via ARC, users have generally found success by following the steps over in our #tinkering category. I suggess you have a look around over there. Here’s an example thread: VPN: step-by-step

I also recommend looking into TailScale, a more robust proxy solution: Tailscale implementation with ARC to circumnavigate ISP CGNAT

These unofficial workarounds might get ARC running for you.

Thank you very much for hint… the info and the links made me understand the idea of passthrough and pushed me to dig into NordVPN settings to find out that the latest versions include a setting to create a Mesh that allows it to invite other devices to link together as a closed loop VPN from anywhere provided Nord is also installed on your mobile device and Mesh is enabled.
I did that and guess what, it worked… even though the ARC test in Roon Core will keep on showing that there is no ARC connection to it.
Hope this info will help other members.
Cheers to all.

1 Like

I appreciate you sharing your insights @Peter_Sabbagh! Do you mind if I merge this into the #tinkering where we’re accumulating nifty solutions such as your own?

Please let me know if there’s something else we can support you with in the meantime.

Sure thing, anything that can help the members, this what the community is for, isn’t it?

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.