Arc configured OK but won't start

roon core running v2.0 on Nucleus
roon remote running v2.0 on Samsung S8 phone running Android v9.0
roon remote says Arc configured OK and connected to network (tick in box)
When I try to run Arc on the phone nothing happens.
What do I do now ???

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Can you say more about what you mean when you say “nothing happens”? Are there any messages showing in Roon ARC?

Arc app is downloaded from the app store and shows the Arc logo on the screen of my phone. If I tap this nothing happens, it just sits there dumb.
No messages, nothing

I would first try uninstalling and then reinstalling the app…

Tried that numerous times with same result

OK, then we’ll have to wait until someone from the Support team picks this up, and that will be after the weekend.

Roon ARC requires Android 9 as minimum, and you say you have 9.0 on your Samsung S8 phone, so there must be something else going on.

Hi @Roger_Smith1,

Please try installing ARC directly using the .apk installer from our downloads page here.

If you continue to have this issue, flag us here and we’ll troubleshoot further.

So I have downloaded Arc file to my windows PC using .apk installer ( Wont run on PC), how do I get it onto my phone? I love listening to music, I hate computers !

1 Like

View this page on your android phone, and press the link supplied above to install Roon ARC.

Ignore last post when I tried it last night on my phone nothing happened , Arc is now running on my phone thank you

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.