Arc connection help required

Roon Core Machine

Synology DS720+ with 8gb of ram

Networking Gear & Setup Details

Asus GT-AX6000, no VPN ds720+ hardwired on ethernet port

Connected Audio Devices

Mainly Yamaha musiccast in the house. OnePlus 8t for the Arc app

Number of Tracks in Library


Description of Issue

Arc doesn’t connect. Fails test in app. I had my room core setup on an old laptop in the house and arc connected without any issues. Decided to change and try out the synogy NAS yesterday. Works well but can’t get Arc to connect. Error details attached

The diagnostics you’ve provided suggest that UPnP is enabled on your network, but your router is refusing the connection. This is either the result of UPnP not being enabled properly on your router, or settings at the level of your internet service provider.

First, to confirm the issue is not with your local network setup:

  • Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Check if your modem is in Bridge mode

If you continue to experience difficulties, we recommend reaching out to your internet service provider and passing along the following questions:

  • Have you implemented carrier-grade NAT for my account level?
  • Have you fully implemented IPv6, or do you have IPv4 addresses available?
  • Can I request a static IPv4 address to support port forwarding?
  • Are there any ports you have reserved at the ISP level I should be aware of?

Wow, quick reply, lots to look at thanks!

I’m away for a couple of days after today but will definately try some if this out.

With the core set up on an old laptop until last week and working “out if the box” would that suggest that it’s probably not the isp?

I was thinking something on the NAS like a firewall but don’t really know how or if that is set up.

I will go through your points one by one later though. Thanks!

1 Like

Changing your core could be the reason. It’s possible that port forwarding / UPnP is set up for the wrong device now. Check your router configuration, and check that the IP address and port match what you shared in the image.

This is the exact issue. New Core is requesting a port that is already in use at router. It’s in use because your old core reserved the port. Either clear this in your router or change the port on new core to something not 55000 (like 55001).

1 Like


Thanks guys.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.