ARC connects from one network but not another

Roon Core Machine

Windows 10, HP Spectre 360, I7, 16GB RAM

Networking Gear & Setup Details

Netgear R6400v2, ethernet connection

Connected Audio Devices

for 4G ARC connection to core: LG G7 running Android 9

Number of Tracks in Library

Description of Issue

I run Roon Server on my HP Spectre laptop, which I move between my primary home and my second home. From my primary home my LG G7 will not connect to Roon Core through 4G using ARC. From my second home, which has same router model, there is no problem connecting through 4G using ARC.

I’m not a techie, so I need help with this. What’s the problem at my primary home if Roon ARC works from my second home with the same router model, and the same laptop and phone with exactly the same settings?

Hi @Kman_CT,

Could it be, in both your homes, that you have another modem/router provided by your ISP that is in the chain before the NetGear router?
Can you please answer the following questions - for both houses - so the community can support you further:

  1. Who is your internet service provider?
  2. Please list the make and model of your ISP modem/router
  3. Do you have any additional network hardware, like additional routers (this would be the NetGear I think) or managed switches?
  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?
1 Like

Thanks for your help. I own the modems at both homes which connect to Netgear R6400v2 routers. The laptop running Roon Server is connected via ethernet at both locations and runs Windows Security plus Malwarebytes Premium. No additional network hardware. No VPN or proxy servers.

Primary home (ARC doesn’t connect): ISP is Comcast. Modem is Netgear CM400

Second home (ARC does connect): ISP is Spectrum. Modem is Arris SURFboard (Older unit. I can’t provide model number until I’m there again.)

So you have if I understand right:

Primary home:
ISP Comcast Netgear CM400 → Netgear R6400v2 → laptop with Roon Core

Secondary home:
ISP Arris SURFBoard → Netgear R6400v2 → laptop with Roon Core

I assume you have a Netgear R6400v2 in both your homes? You don’t move that with you laptop?

So the difference would be the modems supplied by the different ISP’s.
To help you with the situation in your primary home please supply us the diagnostic message that is displayed on the Roon ARC tab in Settings (you can find this in the menu of your Roon app on your laptop or on your LG) when your core is set up in your primary home.

1 Like

Thanks so much for your help. Yes, I have two separate Netgear R6400v2 routers. It’s only the laptop running Roon server that moves between my two homes.

Here’s the Roon Remote error message from Settings > Roon ARC

"connectivity": {"status":"NetworkError","status_code":504,"error":"error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined"},
"external_ip": {"actual_external_ip":"","router_external_ip":"null"},
"natpmp_autoconfig": {"status":"NotFound"},
"upnp_autoconfig": {"status":"NotFound"}

@Kman_CT, the port forwarding diagnostics you’ve provided suggest that UPnP is not properly configured on your router or not working correctly.

Please try the following steps in order:

  • Reboot your Roon Core and networking gear (router, modem, switches, etc.)
  • Try to enable UPnP/NATPMP in the web administration interface for the router
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Try to update your router firmware
  • Check if your modem is in Bridge mode and if not, try to place into Bridge mode

If you continue to experience difficulties, please tag the support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?


Hi @Kman_CT,

It looks like you’ve had some suggestions to follow up on. How are things going on your end? Is there anything we can do to assist further?


I’m not very technical so I’ve given up on Roon ARC from my primary home. I can’t figure out the difference using the same laptop Core at my two homes with identical routers.

Hi @Kman_CT,

The difference is in the different modem/routers of the two different ISP’s. Assuming the settings in your 2 Netgear R6400v2 routers are exactly the same (do you use uPnp to forward Roon or did you set a port forwarding rule in those routers?)

We can try to find out what to set in the Comcast Netgear CM400 if you want.

Hi @Kman_CT,

There are a couple of things to consider.

The IP address between the two locations is going to be different. Not just your external internet IP but likely your core’s local IP address as well.

It also looks like the CM400 has a configuration page and it’s not the same as your typical Arris modem. I found this link that shows how to log in. I get mixed information searching for more information on this device. Some sources indicate it does routing and others unequivocally state that it does not. If you are able to login with the information in the manual, please look for any indication of “bridge mode” and enable it if at all possible.

Get your core online with a static IP address in both locations. This link may help. Please note, doing this may cause issues on public networks and you may need to change your Windows settings back to DHCP. This link describes how to set a Windows 10 device to static IP AND how to revert it back!

At the non-functional location, you might also visit and provide the port number as set up in Settings>Roon ARC. It’s very possible that the ISP is blocking communication on the port.

If you want to keep trying, I am here to help.


1 Like

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.