ARC dies outside WIFI range - No cellular access, just "Poor Connection" even at 100+ Mps over 4G

Roon Core Machine

Roon Core (2.0 build 1128) running on a Nucleus +(

Networking Gear & Setup Details

Askey TCG300 Modem
Lynksys WHW03v1

Connected Audio Devices

Number of Tracks in Library


Description of Issue

ARC does not work on cellular, even while the measured speeds both of my home network and cellular network are exceeding 100 Mbps in download and 12 Mbps in upload.

ARC reports “Poor connection”, or, alternatively, “Can’t connect to your Roon Core”.

However, at exactly the same time, Roon runs normally from all of my remotes.

I will add more details about my network setup regarding my Nucleus + running Roon Server.
You can forget about the Lynksys router, as the Nucleus is connected by Ethernet to the Askey TCG300.
You may be interested in seeing some information on the Askey configuration, including ports. I am enclosing the files

More: Nucleus in the network:

Hi @Antonio_Ballesteros,

Thank you for taking the time to write us.

Having a modem/router combo with a Linksys router connected would create a multiple NAT situation and would make port forwarding difficult in some situations. Ideally, when using your own router, an ISP issued modem/router gateway should be in bridge mode so that multiple NAT isn’t an issue. You can try this. Alternatively, setting up the port forwarding rules in your Askey might just do the trick. Please set up a port forwarding rule to redirect incoming traffic on the port listed in Settings>Roon ARC. This should do the trick but if not, you may want to investigate putting the Modem/Router into bridge mode and connect your Nucleus to your Linksys while setting up the port forwarding there.


1 Like

If your Core is connected directly to the Askey I don’t entirely understand how your home Roon set-up is completely functional but that doesn’t matter for ARC.

On a remote go Settings → Roon ARC and look at the port (may need to click advanced).

It is this port you need to set-up port forwarding on the Askey. OR you can turn on UPnP and see if Roon will automatically configure the Askey. UPnP is debated heavily here and elsewhere on its security so do not just turn this on without at least understanding what it does.

The manual port forward would be: TCP

If your Roon Core is getting a DHCP address dynamically then the 0.21 address may change (like after a power outage). The solution to this is to assign Core a “static” address either manually or through the Askey DHCP configuration.

1 Like

Thanks for the suggestions. I will try them as soon as I get back home in a few days.

1 Like

Thanks again to both of you. I had managed to connect before your contributions by enabling UPnP, but after learning about security risks I tried port forwarding as you suggested:

I started by assigning a static IP address to the Roon core in my network. I did this from the “Fixed Addresses” menu of my Askey modem configuration page

I looked also at a Roon support document at , particularly the section on Manual Configuration. There it says:

Configure Your Router - you’ll need to create a new port forwarding rule in your router that uses these 3 pieces of info

IP address: The IP address of your roon core
LAN/Private/Internal Port: Port 55000
WAN/Public/External Port: This port must be the same as the LAN/Private/Internal port (that is, Port 55000)

I had to try a few times, possibly I was doing something wrong. I rebooted Roon (not sure this is necessary), and it finally worked.

Thanks again

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.