ARC doesn’t connect to core

Roon Core Machine

Mac mini roon core, up to date macOS
iPhone SE, mx9n2lla, 15.6.1

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

ARC connects to core over home wifi, but when I disable wifi on phone, ARC cannot connect.

The install said everything was great but I did notice the core updated itself (without me clicking ok) before I had it on my phone.

Have you set up the necessary port forwarding in your router? Roon ARC needs this to be able to connect to your Core from outside of your home network.

Using a Roon Remote, go to Settings > Roon ARC and see if the Core can automatically do the setup. If not, read this article:

1 Like

It had automatically configured itself during the install. The ARC app would show my music but would never be able to play, always saying poor connection or core not found. I just logged into router and see that the port is set up and active. The port number matches the number on the core, in the settings. I made no configuration changes on the router, simply observed the settings on router and on core. Then I tried again from the ARC app and voíla it inexplicably is now working. For now. Doesn’t inspire confidences, so will see how it goes. Thanks for the article on the port forwarding.

I take that back. I think it was streaming something when it ‘worked’. When I try to play something from my library (a rip of a vinyl) that isn’t available on a stream service, I get core unreachable or poor connection, and it doesn’t play. I’m staring at Core and it is running and present. I have yet to get this ripped vinyl to play over ARC on LTE, though it plays on ARC with phone connected to wifi.

Hi @David_Burkhardt,

I think I can help you with this issue. Can you please tell me about your modem, router, and any networking switches being employed in your setup? Who is your ISP?

Thanks,
Wes

Hi @Wes,

Thank you. Apologies for delays, life is busy.

First, is it okay and advised to upgrade my Mac mini (M1, 2020) that I am using for Roon Core to the new Mac OS Ventura? It is on Monterey 12.6.1 now.

  • I have Verizon FIOS service for internet.

  • There is a box in basement that connects to the external fiber, and connects both CAT6 and COAX to the router.

  • The router is Model Fios-G1100.

  • The Mac mini is using a wifi access point from the router.

(In future I may wish to do ethernet to the Mac mini, with ethernet/optical adapters for the run to the audio room, and potentially replace the Fios router - but probably not for a while.)

Thank you.
Dave

Hi @David_Burkhardt,

What is the access point? Is it some kind of mesh setup?

Thanks,
Wes

I have same issue and very similar set-up. What was the solution?