ARC doesn't work from outside the network

Roon Core Machine

MacMini 2017 with Catalina 10.15.7
ROON 2.0

Networking Gear & Setup Details

UBIQUITI UNIFI Internet USG → UNIFII PoE Switch → MacMini completly configurated with UPNP-enabled and NAT PMP, Port forwarding configured as per https://help.roonlabs.com/portal/en/kb/articles/arc-port-forwarding#Still_having_problems described

Connected Audio Devices

via WLAN

Number of Tracks in Library

Description of Issue

With the newly introduced ARC functionality I would like to use the ARC-App. But Im not able to connect to the core from outside. But I didn’t get to work with your guideline (see above) you provided.

Thanks for your support!

KR
Mathias

1 Like

Hey @Mathias_Zimmermann2,

If possible, please try testing by connecting your core directly to your router and bypass any switches. From there, typically, errors like the one you see can be caused by a misconfigured Port Forwarding setting, if you are not seeing Ready listed in Roon Settings -> Roon ARC, please look over this guide before proceeding.

If you have reviewed this guide and still have not resolved the issue, can you provide the following details about your network setup to help expedite troubleshooting?

  1. Who is your internet service provider?

  2. Please list the make and model of your modem and router?

  3. Do you have any additional network hardware, like additional routers or managed switches?

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?

  5. What machine are you using as a Roon Core, and how is it connected to the internet?

Thanks!