ARC- Double NAT config doesn't like it does with Plex

Roon Core Machine

Dell OptiPlex 7050 MFF - Roon 2.0 Build 1128
i5-7400
16GB
Win10Pro 21H2

Networking Gear & Setup Details

All wired ethernet. Cable->ISP supplied Router (rebadged as NetMaster)->TpLink AX1800 Router

Connected Audio Devices

Kef LS60 (Chromecast)
Naim UnitiAtomHE
Various MacBook Pros and Windows Laptops

Number of Tracks in Library

70K+ tracks

Description of Issue

Can’t get ARC to work. I have a multiple NAT situation. This has been solved by defining port forwarding on both of the routers and Plex is working perfectly like this. Unfortunately, I couldn’t get Roon Arc to work with a similar configuration to Plex.

The IP of the tplink router on the netmaster network is 192.168.1.12
The IP of the Roon server on the tplink is 192.168.0.100 (not static but reserved to connect always to the same ip)
I tried ports 50000 and 20000 and the result is the same.
As stated before, the same config works with Plex albeit from a QNAP Nas.

The copy of the Roon Arc test is as follows:

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“46.2.XXX.XXX”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.0.1”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">718ConflictInMappingEntry</s:Fault></s:Body></s:Envelope>”}
}

The NAT configs of both routers:


Thanks a lot for your support

Yaman

Hello @Yaman_Basa ,

Thank you for your report and for your patience here while your case reached the queue. It is certainly strange that it is working for Plex just fine but not for Roon this way.

Did you reboot the routers after making these settings? What happens if you try to connect ARC to the ISP router directly, does the port forwarding work in that case?

Hi Noris,

It is a bit challenging physically as they are in different rooms and the roon server in a hidden cupboard but I will find time to try and report back.

Thanks a lot

Yaman

That error doesn’t say multiple NAT, I definitely have 2 routers fighting , this my error with xxx’s

{
“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect ECONNREFUSED 154.xxx 193:35641, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“154.xxx router_external_ip”:“192.168.1.254”},
“status”: “status”: MultipleNatFound
,
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.0.1”,“found_upnp”:true}
}

Clearly stating multiple NAT