Arc error , doesnt work

I have updated roon to 2.0 and ditched an old mac desktop that wouldn’t accomodate the upgrade. Unfortunately ARC won’t work i just get an error message .
In my quest to trouble shoot it seems performing surgery on my router was not an option. One roon contributor sang the virtues of another software beginning with P and ending in X . Works a treat remotely, carplay the whole shabang .
This begs the question why am i paying an inflated fee for roon when it doesnt do what it says it can ?

Roon ARC works if you set it up properly. You may need to do manual port forwarding.

@Gregory_Totman, I looked at your activity and don’t see any support questions regarding ARC. If you would like, I can convert this thread to a support request where Roon and the Community can work with you on your questions and try to get ARC working for you.

Robert . Some help in getting ARC working would be appreciated . regards greg

@Gregory_Totman, I converted the category to Support for ARC port forwarding. Can you post the error message you received in Settings → Roon ARC?

screen shot of roon ARC error message , in relation to account of gregory totman

1 Like

@Gregory_Totman, the diagnostics you’ve provided suggest that UPnP is enabled on your network, but your router is refusing the connection. This is either the result of UPnP not being enabled properly on your router, or settings at the level of your internet service provider.

First, to confirm the issue is not with your local network setup:

Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core
Try to manually open the port in your router’s port forwarding configuration
Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
Check for any VPNs or Firewalls that might be interfering
Check if your modem is in Bridge mode

If you continue to experience difficulties, we recommend reaching out to your internet service provider and passing along the following questions:

Have you implemented carrier-grade NAT for my account level?
Have you fully implemented IPv6, or do you have IPv4 addresses available?
Can I request a static IPv4 address to support port forwarding?
Are there any ports you have reserved at the ISP level I should be aware of?

1 Like

Hi @Gregory_Totman,

I understand how frustrating it can feel when automatic configuration fails, and ARC doesn’t work without posting here and spending time tinkering. However, the vast majority of port forwarding snags can usually be resolved with a few minor adjustments, either in Roon or your network settings.

First off, are you able to provide the make and model of the modem and router in your setup? It’s also helpful to know the name of your internet service provider, as many blockages encountered on this forum are at the provider level in the form of carrier-grade network address translation.

Additionally, we’ve enabled more precise diagnostics for your Core. Please keep your Core online for at least one hour at some point in the next few days so the information requested can reach our servers to review.

We’ll be standing by for your response.

i’m sorry it’s taken a while to return your correspondence . I’m still eager to resolve the ARC connectivity issue . Especially now that carplay has just been announced.
I have logged into my ISP account and found the toggle switch for port settings . Am I to presume that toggling the switch from ON to OFF will allow ARC to configure ?
The modem or router is a TG-789 Broadband Gateway . The ISP is IINET .
regards greg

I have managed to get ARC working by toggling the port blocking switch on my router settings . However the ARC settings on my core tell me I’m not connected when the ARC app on my phone appears to have made the connection ??? regards

no point getting my hopes up ARC works only on wi fi switch my phone to data usage and the message is roon core not connecting to core ???

problem solved , re-booted router .ARC up and running without a hitch . regards greg

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.