ARC iPhone App cannot find Roon Core

Roon Core Machine

Roon Core on Ubuntu 20.04LTS, all patches up to date. i5, 16GB.

Networking Gear & Setup Details

Ubiquiti networks security gateway, switches, and access points. Configured correctly (manually, not using UPnP), Roon ARC from the Mac application shows that the Roon Core has been configured and is securely accessible by Roon ARC.

Connected Audio Devices

2 x B&W Z2
1 x Raspberry PI with HiFiBerry Pro DAC

Roon App running on Mac, iPad, and iPhone, all working correctly with no issues
Roon ARC iphone App not working - cannot connect to core

Number of Tracks in Library

Library approx 9000 tracks - note mostly classical so some ‘tracks’ are v. long.

Description of Issue

Downloaded Roon ARC to iphone.
Logged in successfully
ARC shows “No Roon Cores found” on iphone app

legacy Roon app works fine.

1 Like

Just a point of further detail, in the traditional Roon Application settings screen, I have the message:

“Your roon core was automatically configured and has been confirmed to be securely accessible by Roon ARC”.

None of my devices can find the Roon Core using Roon ARC. This is on the same internal network, not external access.

Traditional Roon remote is working fine though.

Hey @David_Green,

Thanks for writing in! We’re not seeing your core linked to your account. Can you confirm it is currently online? Give it a hard reboot just to make sure.

With that, have you gone into arc settings > reset roon arc?

I’ll be on standby for your reply :pray:


The core is definitely on line. It’s using port 46063, not 50000

Hey @David_Green,

Thanks for letting me know. Can you try updating the porter number to 55000. From there, open ARC>Settings and ‘Reset Roon ARC’ and let me know if your issue persists.


The port has now been changed to 55000. I’ve reconfigured port forwarding to work on 55000, and get the message that “Your roon core was automatically configured and has been confirmed to be securely accessible by Roon ARC”.

My iPhone app, on my internal network, still can’t find the Roon Core. The standard Roon Control app on the same iPhone is still working fine.

Any ideas?

Hey @David_Green,

Thank you for the update. Are you seeing a connection issue after resetting ARC? If so, please share a screenshot of the error message you receive.

If possible I would give both your core and mobile device a hard reboot (sometimes doing this a few times helps) and let me know if you continue to run into the same issue.

If so, please write down the date and time and let me know when you have connection issues again :pray:

Ok, I’ve hard re-started everything including the iPhone & Roon Core. This is what I have (Mac application):

iPhone Roon Controller, also working fine:

iPhone RoonARC application (e-mail address obscured) on the same iPhone as the Roon Controller:

Obviously, there are no settings available in the Roon ARC app, and no log files to review to understand why the Roon Controller is seeing the core and working fine, but the ARC app can’t see the core. All happening on my internal network.

Hey @David_Green,

Thank you for the information, and for your patience. To confirm, have you set your router into bridge mode?

Can you confirm that the IP listed at is the same as what your router reports it is? If you supply the port number that is configured in Settings>Roon ARC on that page, can it see you?

If not, something on the network or the ISP may be blocking ARC’s communication. If it’s an ISP-provided modem you may have to change some settings there. ARC will work on any port between 10000 and 65000. I might suggest another port or consult with ISP on what if any ports may be blocked.


I’ve checked with - the IP is correct and as reported by the router. Setting that site to check port 55000 confirms that the port is open and accessible.

BUT - the mobile device that can’t find the core isn’t using the internet to connect; it’s on my home network. The old Roon application on that mobile finds the core and works properly, whereas ARC doesn’t.

Hey @David_Green,

I am going to follow up via PM with next steps :+1:


Thanks for the PM. That has solved the problem - so we can close this one now.

Many thanks for your help with this.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.