ARC is functioning but ARC settings in Roon indicate ARC is 'not ready'

Roon Server Machine

macOS 12.7.5 headless Mac mini (late 2014)
2.6 Ghz i5, 16 gb ram, 256 gb SSD
music files on external USB spinning drive

Networking Gear & Setup Details

  1. Who is your internet service provider?
    Verizon FIOS
  2. Please list the make and model of your modem and router?
    Verizon FIOS G3100 router
    Netgear Orbi RBR50 in AP mode for wifi
    Mac mini is connected to G3100 via ethernet
  3. Do you have any additional network hardware, like additional routers or managed switches?
    no
  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?
    no

Connected Audio Devices

all endpoints are wifi, rare if any issues with dropouts, etc
Wiim Pro → coax → Schiit multibit Gungnir dac
NAD C338 via Chromecast
NAD M33 via wifi
Naim Uniti Atom HE via wifi
HomePod mini via Airplay 2
Sonos Play:1 stereo pair

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

ARC plays. I was using it at work earlier today and just tested it again now. We had some storms go through, no power outages at home as far as I know of, no lightning in the immediate vicinity. However, looking at the ARC settings in Roon, I see a “Not Ready” message. The full message is “Port 55000 is already in use. Either change the listening port or close any applications which may be using this port.” Screenshots from Roon and from ARC on my phone are below.

The only other applications running are Virtual Box to run a DietPi virtually for Roon extensions and Apple’s native Screen Sharing app which is what I use to administer the headless mini. I’ve power cycled the server, the Orbi, and the Verizon router, no changes. ARC works, but indicates it’s not ready. I haven’t changed anything, updated any router firmware, etc. ARC has been working wonderfully for me for a long long time. Any thoughts or suggestions to prevent a potential ARC failure would be helpful. At the very least, I’d love an explanation of how ARC is working if it’s not ready. Thanks!

I seem to have resolved the issue with the ‘Reset’ button next to the window that indicates the port. I clicked reset twice - the first time, it cleared the 55000, the second time it added 55002 and gave me a ‘Ready’ indication and all seems to be working. I can see a reply incoming from Roon support - thanks for taking a look!

1 Like

Hi @kneville,

Thank you for your inquiry and we’re certainly glad ARC is working properly despite the port test indicating otherwise in Roon Settings.

We’ve taken a closer look at diagnostics to uncover the real story. Turns out, the port test fails to run in the first place because other software on the machine is already using the port. In this case, “not ready” more factually indicates “can’t test.”

We suspect the Oracle VM may be responsible for tying up the port during the port test. You can certainly try disabling the Virtual Box to see if that resolves things. However, it’s largely irrelevant to ARC; a positive connection to RoonServer in ARC on cellular data means you don’t have a NAT layer, interference from redundant security, or any other ISP-level blockages here. The port test doesn’t ping the phone, only our servers through the port.

The only real risk is that whatever software is tying up port 55000 may decide to use it, preventing the actual mobile service, not just the port test, from operating on that port. If this happens, simply try another port, like 56000 or 55005.

You can also bypass any blockages to port forwarding if you turn to a proxy-mesh VPN like Tailscale by installing it on both the RoonServer machine and phone and setting up a single Tailscale subnet.

1 Like

I appreciate the speedy and detailed reply, @connor. I have to say, among the majority of tech topics, networking is my Achilles heel - that’s part of why this was upsetting - I’m not sure I could reproduce the steps I took to get things working back when ARC was introduced if I had to reset something or a firmware update had mucked things up. In any case, I’m back up and running with a ‘Ready’ indicator and could easily turn off the VM if that got in the way.

Thanks again for the rapid response, cheers!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.