ARC: Issues with specific HiRez tracks on Lossy quality

Roon Core Machine

The same as here:

Networking Gear & Setup Details

The same as here:

Connected Audio Devices

The same as here:

Number of Tracks in Library

The same as here:

Description of Issue

See here:

Same here!

Hi @my_changed_username,

The server issue which lead to widespread symptoms last month has long since been resolved and there are no recent outages. The issue you’re experiencing in ARC is likely a result of connectivity issues with your LAN or mobile network.

A quick investigation of logs from the reported time window in ARC reveals multiple timeouts from unrelated services. By all indications, the connectivity dropouts were unexpected and did not allow sufficient time for ARC to cache streaming content in advance as intended.

However, Core account diagnostics show syncing errors with ARC. I recommend you uninstall Roon ARC and reinstall it on your mobile device, in case there’s a database malfunction on the mobile install. This shouldn’t affect any saved preferences in Roon or your library, although you may need to reset your cellular quality settings when you reinstall.

Please let me know if the tech support team can assist further. Thanks!


If you continue to experience this error message after attempting 1) a mobile device reboot and 2) a reinstall of ARC, then respond here and we’ll happily start a dedicated support thread. Thanks!

1 Like

Despite restarting the Arc endpoint (Galaxy Fold 3), Roon Arc wasn’t able to playback anything.

When I attempted to reset through the app settings, it become frozen.

Uninstalling and re-installing helped temporarily, was able to playback for like 3 minutes. Then it stopped playing again.

What does the diagnostics show now @connor , the same kind of errors?

The only idea I have as of now is if the issue somehow does not relate to app notifications - I keep receiving quite a lot of them today (emails from Gmail, NFC card payments, …). Could that data traffic somehow interrupt Arc from correctly buffering?

EDIT: Did another reinstall, works again. Will keep listening and report back how long it lasted this time :slight_smile:

EDIT: Worked for like 15 minutes until I received an email notification from Gmail. Now it does not work anymore again o_O

EDIT: Reinstalls not necessary anymore, just restarting the endpoint is enough. But after receiving a Whatsapp message, it stopped playing again. Muting notifications didnt help.



The issue is triggered when playing the following 24/48kHz track with “Lossy” quality settings:
Dragonforce - Three Hammers (24bit/48kHz version purchased from Qobuz)

It tends to be triggered at around 5:30 - 5:40 timestamp. It happens on both cellular and wifi connectivity with “Lossy” playback but NOT with “High Quality” playback. It happens with flac as well as wav 24bit/48kHz version downloaded from Qobuz but not with 16bit/44.1kHz version of the same album also downloaded from Qobuz. It does not happen with any of the other several tracks from the same 24bit/48kHz album I’ve checked.

Once the issue is triggered, Arc becomes overall less responsive and keeps playing back unreliably with “Unexpected playback error” or “Poor connection” messages (even with other tracks) until I restart Arc or (even better) the Samsung endpoint.


  • Download the track/album to Roon Arc, OR
  • Set “Original Format” playback quality before starting to play the track/album.

The issue is also triggered when playing the following 24/48kHz track with “Lossy” quality settings:
Cellar Darling - Six Days (24bit/48khz version purchased from Qobuz)

It tends to be triggered around 5:35-5:45 timestamp. Otherwise the issue description from the previous post applies here too.

I have performed a full reset of my core device, with a clean Windows 11 installation. The issue still persists.

Hi @my_changed_username,

While I recognize it’s been some time and the longevity of this issue has tried your patience, our investigation is ongoing and we’ve made progress in identifying and resolving a potential bug related to “Lossy” playback of Qobuz content. Most likely, the symptoms you’ve reported will subside once we release a fix. We’ll post an update in this thread as soon as we have more information. Thank you!

Hi connor,

thank you for the update. I definitely keep this thread in mind but have not been able to spot another hirez track where the issue would be happening for me. It seems like a strange re-encoding issue.

Should I stumble across another track causing the same issue, will let you know! So far just the two mentioned above.

1 Like

Thanks for the update @my_changed_username! Out of curiosity, have you been able to reproduce this issue with those tracks on any endpoint with Roon/Roon Remote?

There are two known issues in the pipeline for a fix concerning Qobuz transcoding. In one case, Roon itself misreads certain Qobuz high-quality tracks as MQA and incorrectly decodes them (see here: Certain Frank Sinatra Qobuz Tracks Won’t Play in Roon (Ticket In). However, ARC plays back perfectly in those cases.

The second issue is the one I mentioned in my previous post, most likely affecting you here. We’ll keep you posted. Thanks for your patience in the meantime.

Hi, after updating to 2.0.9 my problem is solved. Frank plays nicely the whole Watertown album.


Hi @connor ,

I’ve got another clue:

  1. When I directly search for either of the two hirez tracks in ARC and click on it to initiate playback ( = only the one track is in the playing queue), the issue does not occur with the Dragonforce track but occurs with the Cellar Darling track.
  2. When I start playing either of the two hirez tracks in ARC from related album screen ( = the track and all remaining tracks of the album are added to playing queue), the issue occurs with both tracks.

The above is happening from two different ARC end-points (Samsung Fold3, Samsung S22).

Regarding your question - The issue is happening just from ARC, no issues when Roon Remote app on the two above end-points is used to playback the two tracks.

The issue is also triggered when playing the following 24/48kHz track with “Lossy” quality settings:
Epica - Code of Life (24bit/48khz version purchased from Qobuz)

It tends to be triggered around 5:40 timestamp. The issue only happens when I start playing from related album screen (the track and all remaining tracks of the album are added to playing queue). (When only the one track is in playing queue, the issue is not triggering.) Otherwise the issue description from the previous post applies here too.

Hi @my_changed_username,

We’ve merged some fixes to transcoding errors since your latest post. Are you still experiencing this problem?

Just tried to play the Epica track… and triggered the issue again. I have upgraded my core as well as Arc yesterday.

Do you want me to play all three tracks again and give you the exact timestamps when the issue got triggered for each, so that logs can be checked for error details?

@connor The issue triggered at the following timestamps:

Epica - Code of Life:
2023-02-16 16:50:38 CET (UTC/GMT+1)

Dragonforce - Three Hammers:
2023-02-16 16:58:15 CET (UTC/GMT+1)

Cellar Darling - Six Days:
2023-02-16 17:09:22 CET (UTC/GMT+1)

(Audio playback stops near the end of each track, the play icon in ARC turns into a spinning-wheel for like 15-25 seconds, then the icon turns into an arrow and “Poor Connection” or “Internal Error” message is received. Until ARC is manually restarted by me, hitting the play icon does not result in resumed playback, instead the spinning-wheel and then error message re-occurs.)

@connor The issue is also triggered when playing the following 24/48kHz tracks with “Lossy” quality settings:
Insomnium - 1696 (24bit/48kHz version purchased from Qobuz)
Insomnium - The Rapids (24bit/48kHz version purchased from Qobuz)

(Around 6:03 timestamp in case of 1696, around 7:28 in case of The Rapids.)

Hi @my_changed_username,

We’ve put in quite a bit of work around both connectivity and playback engine stability in the last few releases. Your notes and feedback in this thread were quite helpful in illuminating improvement areas for development.

How have things been performing in ARC more recently? Have you still experienced dropouts with certain sources or filetypes? Any high or low points?

I’ve just tried to listen to the track again in Roon Arc. First without transcoding (Cellular = CD Quality), all was working fine. Secondly with transcoding (Cellular = Balanced), triggering the issue again. So the issue does not seem to be fixed.

To avoid the issue, I’ve just got used to listening without any transcoding. Fortunately I’ve got sufficient mobile data plan for that.

If I get to change my Roon core in the future, will try again and report back.