ARC keeps disconnecting from Roon Core

Roon Core Machine

Nucleus, wired directly to XFinity

Networking Gear & Setup Details

XFinity 1.2 GB/s

Connected Audio Devices

Linn Select + Katalyst, wired.

Number of Tracks in Library

All streaming from Qobuz

Description of Issue

Team,
I appreciate the idea behind Roon 2.0/ARC, but must say, for me, it has been nothing else but discomfort. I spent more time resetting all my network to make it work, and still with limited success. And I dont like to pay for a service I dont fully get :wink:
I have to reboot my Nucleus Core on a daily basis if I want tohave access to ARC. I get this message from the app ’ Can’t Connect to your Roon core ', whilst it’s all working from my home.
Of course, by the very nature of ARC, there is nothing I can do about it when travelling, so, it saves no purpose and just frustrates me.
Exemple here
(Side question" is this strange ::ffff: on the core address a clue?)

What solutions here?
Thanks

This I can answer. It means you have IPv6 in your network which should be fine.

1 Like

@JB_RIVAIL, please complete the support template in more detail, and include information about your network and ISP. Likewise, please provide screenshots of Settings > Roon ARC after rebooting the Nucleus and when you have a problem.

Thanks @Martin_Webster - appreciate your swift feedback tremendously. You guys are great.
Where is the Support Template and what further info on my network (Gateway / Nucleus wired) and ISP (xFinity Cable 1200Mbps)

Had to do this operation yesterday again, and here was the message error:
Again - rebooted the Nucleus from its IP address, and it worked as a charm… until now!

{
"connectivity": {"status":"NetworkError","status_code":504,"error":"error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined"},
"external_ip": {"actual_external_ip":"24.22.xxx.xxx","router_external_ip":null},
"natpmp_autoconfig": {"status":"NotFound"},
"upnp_autoconfig": {"server_ip":"10.0.0.1","found_upnp":true,"error":"<?xml version=\"1.0\"?>\n<s:Envelope xmlns:s=\"http://schemas.xmlsoap.org/soap/envelope/\" s:encodingStyle=\"http://schemas.xmlsoap.org/soap/encoding/\">\n<s:Body>\n<s:Fault>\n<faultcode>s:Client</faultcode>\n<faultstring>UPnPError</faultstring>\n<detail>\n<UPnPError xmlns=\"urn:schemas-upnp-org:control-1-0\">\n<errorCode>404</errorCode>\n<errorDescription>Error</errorDescription>\n</UPnPError>\n</detail>\n</s:Fault>\n</s:Body>\n</s:Envelope>\n"}
}

It was in your opening post. But no need to worry now. However, please provide the make and model of your modem/router provided by the ISP, and any another network equipment connected. :slightly_smiling_face:

The port forwarding diagnostics you’ve provided suggest that UPnP is not properly configured on your router or not working correctly.

Please try the following steps in order:

  • Reboot your Roon Core and networking gear (router, modem, switches, etc.)
  • Try to enable UPnP/NATPMP in the web administration interface for the router
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Try to update your router firmware Check if your modem is in Bridge mode and if not, try to place into Bridge mode

If you continue to experience difficulties, please tag the support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

Thanks!

1 Like

Possibly really silly question, but you said that you only stream from Qobuz. So why do you need ARC? Just curious…

That’s a fun one! I guess, to have my listening history up-to-date (and the metadata quality of Roon), the Radio and Playlists quality of Roon. But to your point, more a confort than a necessity.

1 Like

Hi @JB_RIVAIL,

I’m with you on wanting my Roon features to travel with me so I totally get it!

Will you try the suggestions that, @Martin_Webster offered on configuring port forwarding manually? Alternatively, Xfinity might be able to give you some detailed instructions for your device so keep that in your back pocket too. Just be prepared to tell them what you’re trying to do and know your nucleus IP address/port configured in Roon>Settings>Roon ARC setup. They SHOULD be able to get it going for you.

Wes