ARC not able to communicate with Core

Networking Gear & Setup Details

  1. Who is your internet service provider? Xfinity
  2. Please list the make and model of your modem and router? tg4482a
  3. Do you have any additional network hardware, like additional routers or managed switches? No
  4. Does your network have any VPNs, proxy servers, or enterprise-grade security? No

Unable to have ARC access my CORE.

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“actual_external_ipv6”:“2601:189:4180:67e0:1c75:2970:a101:d125”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

Hey Brian, just went through this setup process, you’ll need to make sure your router has either UPnP enabled or you manually open a port with the suggested port number (or one of your choosing) from the Roon arc section. I’m not a networking expert but I’ve seen security issues using UPnP so opening a port manually might be your best option. Hope that helps.

I’ve tried all of those options and nothing is working. Can’t imagine what I am missing here. Is there a way to get technical assistance from Roon on this? Already spent countless hours trying to figure this out.

Hey @brian_pedersen,

Thanks for your patience while we work through each thread. As @Derek_Clark1 mentioned, based on the error code you shared above, Roon seems to think UPnP is disabled on your router (which can sometimes be the case when setting up a manual port forwarding rule.)

First, can you please try enabling UPnP back on your router and then give your core a restart?

With that, I would also disable ipv6 for now and make sure only ivp4 is active. Here is more info on your specific router:

We’ve seen a handful of issues pop up around the ‘Advanced Security’ settings on some of these Xfinity routers. If none of the above helps, I would test out temporarily disabling this advanced security feature and see if things improve.

I’ll be on standby for your reply :+1:

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.