Arc not auto-configuring my router

Roon Core Machine

Nucleus Core
Music stored on QNAP TS-251

Networking Gear & Setup Details

Router is a Draytek VIGOR 2860
NETGEAR Prosafe 5 Port Gigabit switch
WiFi and Ethernet, no VPN

Connected Audio Devices

Number of Tracks in Library

3,000 tracks

Description of Issue

I have upgraded to roon 2 and downloaded ARC on my iPhone. I can play music using ARC at home but not outside. I have enabled UPnP and Connection Control Service. When I run the ARC test I get this message.


Can you help please?

You don’t seem to have UPnP enabled on your router. Either enable this or setup port forwarding.

Hi Martin

Please see screenshot below showing that I have enabled UPnP.

With regard to port forwarding, is this the same as port redirection? Please see second screenshot.

Does your DSL line connect directly into the Vigor, or do you have a modem provided by your ISP?

I suspect it’s via a modem. My ISP is BT. I enclose a photo of what might well be the modem and also of the front connections of my Visor, does this answer your question?

image
image

It looks like you have OpenReach fibre and use an ECI modem. AFAIK PORT 1 should be connected to the WAN port on your Draytek, and this should handle PPoE. Can you confirm is this is correct?

It looks that way although I can’t identify anything called an AFAIK PORT 1. Here is a screenshot of the dashboard of the Draytek which may help?

Sorry forgot to past the screenshot, here it is:

He meant the Port 1. AFAIK = As Far As I Know :slight_smile:

This seems to be the Port 1:

AFAIK means as far as I know, but don’t worry, it looks like the modem is setup for pass through.

PORT 1 is on the OpenReach modem.

I’ll take a closer look tomorrow, as it’s getting late here, but it looks like port forwarding isn’t setup correctly.

Thanks Martin

1 Like

@Peter_Goodman, please accept my apologies for not getting back to you sooner.

From what I can see, it looks like the modem is in bridge mode. Therefore, it is likely that UPnP is not properly configured on your router or not working correctly.

These are the steps in order, that should be tried:

  • Reboot your Roon Core and networking gear (router, modem, switches, etc.)
  • Try to enable UPnP/NATPMP in the web administration interface for the router
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Try to update your router firmware
  • Check if your modem is in Bridgemode and if not, try to place into Bridge mode

Can we work through these one at a time? If you can confirm the exact model of Draytek router that will help as I can search for the correct handbook.

OK Martin. I’m not any expert in router language but I can try the first couple of instructions. I’m not sure I know how to “manually open the port in the router’s port forwarding configuration”?

The router is a Draytek Vigor 2860 Annex A

Use the “Port Redirection” instructions from Draytek’s help article here:

1 Like

Thank you for forwarding this to me Suedkeiz, I will see if I am up to the task. I’m not a techie, just a massive music lover!

Hi Martin

I have tried rebooting the whole system.

I have ensured UPnP under the NAT tab is enabled but Roon ARC still reports “Not Ready”

I have enabled Index No.1 under the NAT>>Port Redirection tab but am unsure about what to enter. I attach an annotated screen shot. Can you advise what I should enter into the fields?

Follow the guidance posted by @Suedkiez (link below), and use the following settings:

  • Mode: single
  • Service name: RoonARC
  • Protocol: TCP
  • WAN interface: ALL
  • Public port: what you see in Roon > Settings > Roon ARC, e.g., 55000
  • Source IP: any
  • Private IP: the IP of your Roon core
  • Private port: same as publiuc port
1 Like

Martin, great news, I created the forwarding configuration and suddenly everything is working fine! I’ve tried ARC on 4G and this is also working which is perfect as we’re going on holiday later this week and I can listen to all my lovely music while away. Thank you and @Suedkiez so much for your help.

2 Likes

Excellent news. Before you go away, be sure to turn off automatic updates on your core and mobile (just in case there is an update and your core needs a restart—which you won’t be able to perform.)

In Roon Remote go to Settings > About and click on the gear to change the setting.

On iOS, go to Settings > App Store and disable app updates. Not sure how to achieve this on Android.

OK Martin, I have done that but I don’t quite understand the relevance of this – does that mean I can’t install updates in the future?