Arc Not Configuring with Synology RT2600ac

Roon Core Machine

Intel NUC i5 8GB RAM

Networking Gear & Setup Details

  1. Who is your internet service provider? FiOS

  2. Please list the make and model of your modem and router?
    -FiOS (Unsure of model)

  3. Do you have any additional network hardware, like additional routers or managed switches?
    -Synology RT2600AC (connected to FiOS router)

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security? None

Connected Audio Devices

-Sonos ARC home theater setup
-BlueSound Node2i
-LG C9 OLED
-Google Home Mini
-Chromecast Audio
-Nvidia Shield TV Pro
(The above devices are connected, either via ethernet or wireless, to the Synology.

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“98.aaa.bbb.ccc”,“router_external_ip”:“192.168.1.153”},
“status”: “status”: MultipleNatFound
,
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“10.0.4.1”,“found_upnp”:true}
}

I feel like I’ve tried all the troubleshooting steps listed on the Roon support pages. As far as port forwarding, I’m not sure if I am doing it right. I tried putting the Synology Router in bridge mode, but then it couldn’t find the Roon Core on the NUC. It is currently in “wireless router” mode. I tried finding where to enable uPnP/NATPMP, but all I see is a pop up box showing “restore UPnP rules upon starting” box enabled.

Hi, just so you you know, I have a working ARC with the Synology router (so hopefully that rules out one possible root cause).

To get it working I had to put my ISPs modem/router in Bridge mode - then the Synology worked without needing any configuration beyond enabling UPNP.

I suspect you will need to do something similar, although I have no knowledge of your ISP and this specific router.

Try and put the FiOS modem/router into bridge mode and see what happens (as a first step)

Hey @Eleazer_Espinosa,

Thank you for your patience while we’ve diligently worked to reach every request for support with port forwarding. The diagnostics you’ve provided suggest there is a redundant layer of network address translation preventing port forwarding.

This can either be at the local-network level (commonly as a result of two routers), or at the level of your service provider (in the form of carrier-grade NAT).

If your setup involves an ISP-provided gateway (modem/router combination) and your own third-party router:

  • In the web administration interface of the ISP-provided gateway (modem/router combination), enable Bridge Mode or equivalent, where the ISP-provided gateway does not have DHCP routing enabled.

  • Alternatively, if you have already created a manual port forwarding rule in your 3rd party router, you can add an additional rule to forward the port through the ISP/second router.

If you only have one router in your setup or your modem is already in Bridge mode, please take a look through our list of known router and internet service provider solutions, as other users may have already encountered the same situation: ISPs and Routers: List of Known Solutions and Workarounds

You can reach out directly to your service provider to ask if they support port forwarding; this question will often enough to prompt them to explain whether or not the carrier-grade NAT they’ve implemented can function with ARC.

More specifically, you can pass along the following questions:

  • Have you implemented carrier-grade NAT for my account level?
  • Have you fully implemented IPv6, or do you have IPv4 addresses available?
  • Can I request a static IPv4 address to support port forwarding?
  • Are there any ports you have reserved at the ISP level I should be aware of?

If you’re unable to locate an existing solution in our #support:port-forwarding-resources subcategory, please reach out to the Roon support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

Thanks. I will look into this.