ARC not connecting to Core despite confirmed setup

Roon Core Machine

Wolf Audio Alpha 3 running Windows 10
Ethernet connection to Wolf

Networking Gear & Setup Details

  1. Who is your internet service provider?

ISP: Spectrum 400 mbps
2) Please list the make and model of your modem and router?
Modem: Spectrum provided Docsis 3.1 eMTA
Router: TP-Link Archer AX73
3) Do you have any additional network hardware, like additional routers or managed switches?
4) Does your network have any VPNs, proxy servers, or enterprise-grade security?

Connected Audio Devices

Wolf Alpha 3 running Windows 10
Ethernet connection to Wolf

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

Roon ARC Settings shows that the router is configured correctly.

But ARC cannot connect. I get this message:

Weirder still, under the Setup tab when I click Find my Core… it cannot find my core even though I’m listening to music on Roon.

Phone is new iPhone 13.

I’ve asked Wolf to connect and check my firewall settings, but this hasn’t happened yet.

Any help is appreciated!

Update. Yesterday after deleting and re-downloading ARC I got a popup asking to allow access to devices on my network. I allowed, and ARC began to work. I opened ARC app setting on my phone and Network Access was shown as turned on. Thought I was good to go… But…
Today I opened ARC and it connected to my core but there was a message at the bottom that says UNAUTHORIZED, and a POOR CONNECTION message. App settings showed Network Access was on.
After no success connecting, I deleted app and re-downloaded again. No popup to allow access to devices on LAN. No connection. Went to app setting and now there is no menu item for Network Access. What??
I’m confused and still dead in the water. ARC can’t connect to my core. The Wolf Alpha 3 with my core can’t find my core. Total mess.

Update 10/30/22. The techs at Wolf checked my settings, firewall, etc. No issues found. Turned off firewall completely to test. No change. Can’t connect.
iPhone ARC settings still show no option to connect to devices on my network.
Any help would be greatly appreciated. I’m going to drive close to a thousand miles this week for work and I would love to access my core! :slight_smile:
Thanks, everyone!

This is a misunderstanding. The message says “Searching for Roon OS Core” - in other words, it’s looking for a Core that is running on Roon OS (Operating System). You are running your Core on a Windows 10 OS.

Roon OS is used only on the Nucleus and Nucleus+ or on DIY Intel NUCs that have had Roon OS installed on them using ROCK.

Thank you for the clarification on the OS.
I reinstalled Arc on my iPhone 13. Same issue. Then I opened the app settings and turned on every possible toggle under Siri & Search. 30 seconds later I got a popup asking if I will allow Arc to access devices on my network. I allowed, and it connected to my core. Now app settings shows Local Network toggle and it’s on. Arc working. Will update in a few days. Previous time it connected only for one day and then could not connect again.

Hi @John_OMeara,

Your patience has been admirable these last 21 days waiting for a staff response as we worked our way through the queue of ARC-related issues.

We’ve investigated diagnostics from your account, and there’s strong evidence suggesting that ARC is attempting to authorize to stale data left over from an old Roon Core, either on your current Core machine or a previous Core device.

While I’m kicking myself that we didn’t get a chance to issue these steps to you before you left on your work road trip, it’s very likely you can give ARC a chance to connect after refreshing the database on your Core. This will not eliminate your custom settings or Library provided you backup and restore.

  • Create a Backup of your current database
  • Exit out of Roon
  • Navigate to your Roon Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Verify if the issue persists on a fresh database before restoring the backup

Please let me know if these steps help!

Hi Connor,
THANK YOU for diagnosing my issue and providing clear-cut directions on how to fix it. The instructions worked perfectly, and I’m now up and running.
One note: I made the changes and everything worked. My core name was changed and Roon Remote and Arc connected easily. The next day I restored from my backup file. Afterwards, my core name was back to the previous name and the connection issues were back, too. I once again followed the directions and again it fixed the issue. I won’t be restoring again. I’m not worried at all about the backup file - I think the only thing I will miss is a playlist or two, but no problem. I’m super happy to have Arc working. Thank you again!

1 Like