ARC Not connecting (UPnP ON, POR_FWD Done)

Roon Core Machine

Mac Studio M1 Max
Roon 2.0
Monterey 12.6

{
"connectivity": {"status":"NetworkError","status_code":502,"error":"error: Error: connect ECONNREFUSED 0.0.0.0:55002, response code: undefined, body: undefined"},
"external_ip": {"actual_external_ip":"45.127.44.18","router_external_ip":"45.127.44.18"},
"natpmp_autoconfig": {"server_ip":"192.168.2.1","found_natpmp":true},
"upnp_autoconfig": {"server_ip":"192.168.2.1","found_upnp":true}
}

I have tried UPnP On and Off.
Tried Port forwarding and port triggering.

I always get the same error econnrefused.

Any ideas please?

When you have a moment please post some additional information including the name of your ISP as well as details about the router and other network hardware in use.

Fiber till home from TATA PLAY INDIA.
NOKIA ONT -LAN CABLE-> Asus RT-AC86U

Both uPnP On.
Both Portforwarding enabled.

Hey @Marco_Cebrian,

On certain ASUS routers, you may need to enable uPnP + Port forwarding in a few different areas in your router settings. Give this thread a read and let me know if it helps:

https://community.roonlabs.com/t/upnp-arc-issue-on-router-asus-ac68u/213444/22#:~:text=your%20case%3F%20Thanks!-,Hi,-Penny.%20I%20accidentally

I’ll be monitoring for your reply :+1:

Hi, thanks for the reply.

It was already enabled in all 3 places. No difference. It cannot connect.

I have IPv4 and IPV6 on. IPV6 with a dedicated fixed ip that is visible from outside but roon is using only ipv4 which when I check on cantouseeme website can’t access any port.

I tried 100 things… Nothing work but, if I connect my Mac studio directly to the ONT, without the Wireless router, I get this:

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“xxxx”,“router_external_ip”:“10.147.140.226”},
“status”: “status”: MultipleNatFound
,
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.1.254”,“found_upnp”:true}
}

Mac → ONT via cable.

The Mac is set to be in the DMZ and still it is not working.

Hey @Marco_Cebrian,

Thanks for the information. There are a few things going on here that should be mentioned:

Setting your machine to DMZ does put you at wider security risk and we advise against doing this if at all possible.

Because you still got this error after connecting your core to the main router, it points to your router being CG-Nat, in which case you may need to contact your ISP to request a static IP. You can read more about that from our help article on the subject here:

Please let me know if you have any additional questions here.

-Ben

1 Like