ARC not connecting

Roon Core Machine

this is the info from the app below. i confirmed upnp is enabled and disabled it and re enabled. no change.

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“x.x.x.x”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
}

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Hi @Brian_Runge,

Thanks for reporting your issue. I’m going to look at some diagnostics. Do you mind sharing your ISP and modem/router type?

Thanks,
Wes

I’m seeing the same diagnostic output on my configuration, bar the IP address obviously.

On that subject, it might be a good idea to obfuscate externally facing IP addresses in ARC problem reports.

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“xxx.xxx.xxx.xxx”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
}

My setup is through CenturyLink in WA, USA and uses a C2100T Technicolor modem/router (192.168.0.x) with a Google NEST mesh network (192.168.86.x) connected behind it. For Roon to see everything, it has to all be on the same subnet as the Roon ROCK (in my case).

FYI, I have manual port-forwarding successfully configured for two PLEX servers (192.168.86.x:32400) to be remotely accessible, and configured manually for the Roon ROCK device (192.168.86.x:55000) also.

Cheers!

Hi Brian,

Thank you for the wealth of information here.

Are you still able to open the modem interface via 192.168.0.1? If so, this indicates there might be a double NAT situation. If possible, can you put your modem in bridge mode to see if anything changes?

Thanks,
Wes

According to several tests I don’t have a double NAT situation. Running tracert shows only one private address, not two as you’d expect if I had double NAT.


The second listed address is public:

I’ve tried disabling NAT on the C2100T as a test and all networking connectivity breaks when I do.

Hi @Brian_Murphy3

All I can see from logging are errors related to finding your storage locations and a couple regarding image download failures. Otherwise, the error you’re getting when you test indicates an issue with forwarding.

What happens when you go to canyouseeme.org and provide the port 55000?

Thanks,
Wes

There is no route to the port.

I’ve captured maybe six different diagnostic outputs from Roon ARC’s config page, all showing different results.

The root of my problems with Roon is that Google Nest Mesh configurations create a separate subnet (meaning all devices on the other subnet are invisible to Roon) and that it can’t be disabled from doing NAT.

Taking a step back, I decided to try two things:

  1. Move the Roon ROCK to one of the C2100T’s ethernet ports to remove the Google Nest Mesh network as a factor and test whether Roon ARC works, and then…

  2. Reconfigure my modem into transparent bridging mode and allow the Google Nest WiFi network to connect over PPPoE and remove the double NAT problem.

Option 1 resulted in Roon ARC coming up as configured correctly under settings in Roon remote OS X app, but the Roon ARC iOS app wasn’t able to connect when I tried over a cellular network. Tried restarting the app and restarting the iPhone, but I could not get the ARC client to connect to my (allegedly) correctly configured and accessible Roon ROCK. Moving on…

Option 2 was even less productive. I reset both modem (after a config backup) and Google Nest Mesh router to factory and configured the former to Transparent Bridging mode, and then tried to configure the latter to sign in with a PPPoE connection. With the correct credentials I kept getting a VLAN ID error from the Mesh router. Google support (in the Philippines) blamed CenturyLink’s modem because their diagnostic showed that the Mesh router had not been given a DHCP address (192.168.0.x) by their modem, while other connected devices had.

Talking to CenturyLink, they (via their call center in the Philippines) said that it would be next to impossible to figure out the problem because I had a “near obsolete” modem (supplied by them). They told me I’d need to talk to customer care about renting or buying a new modem and, in the act of transferring me to them I was disconnected. Sigh. I restored the saved configuration to the C2100T and reconfigured the Mesh router to roll back to the previous configuration.

After a soothing cup of tea to lower my blood pressure, I called CenturyLink Customer Care and calmly explained what I’d been told and why I was cancelling my service with them. Magically, I’m getting a new modem, my fiber optic service increased to 200mbps both ways, and my bill reduced by $70 a month.

My new service self-install is tomorrow and once it’s in and working, I’ll be replacing the Google Nest Mesh nodes with just about any other Mesh network that doesn’t create a separate subnet. With the configuration updated and simplified I’ll take another swing at configuring Roon ARC. I’ll do some more digging in the forums here to see whether anyone else had the same situation as me under option 1.

Cheers!

1 Like

Thank you for the update. Hopefully, the new modem will do the trick for you.

Wes

Hey @Brian_Runge,

Have you made any progress on configuring ARC to be remotely accessible?

Cox Communication ISP
Netgear Nighthawk RAX45
Netgear CM 1100 Modem

Running on ROON Core Kit and Lumin S1 Streamer most of the time or various Bluetooth sources.
image

FYI, probably unrelated to this issue: When changing the router, remember to manually release the internet/WAN IP first. ISP side can have a technical configuration that prevents user from getting more than one IP address at a time - this can prevent the new router from obtaining a WAN IP properly.

I’d prefer users not to use mesh if they can, but if you have to use mesh, perhaps check out TP-Link. This brand is probably somewhat less problematic than several others. Stay away from Linksys.

Keep the ISP modem/router in bridge mode - unless you determine to use an Eero, which only works in bridge mode so the router cannot be in bridge mode.

Hey Peter,

What’s the technical reason/s you think mesh WiFI should be avoided? I’ve had to go to mesh to handle challenges getting good coverage and performance in my 110 year old home.

I’ve been considering a 6E solution, but the price premium is daunting. I’m leaning towards passing on the Eero and TP-Link brands because of their privacy and data collection policies. A pity as the TP-Link Deco W7200 looks pretty appealing overall. Cheers!

Not that they are bad, but if mesh users encounter a network problem, I usually cannot help fixing.