ARC Not Working Since Update 1223 [Fixed in core build 1232]

Sadly, it seems that the latest update has broken Roon ARC :cry:. Back to the drawing board. Was working seamlessly before.


Hi @Sean_Pierce,

We’re certainly sorry to hear that’s the case. Just for due diligence, have you tried fully deleting and reinstalling ARC? That should remove any authentication mismatch between ARC and Roon from an error during the update.

What are the particular symptoms you’re experiencing? Are there any new diagnostics in the Roon ARC tab?

We’ll be standing by to help resolve the issue and restore ARC as soon as possible.

Thanks so much for following up. I’m running Roon Server on a dedicated M1 Mac Mini (Ventura). I did a reinstall yesterday (both Roon Server and Roon on the same machine) as well as Roon ARC on my iPhone and was able to reconnect to Roon ARC, at least temporarily. I also rebooted my router and home network. It failed again this morning without any additional intervention. No diagnostics, just an endless spinning loop icon. I reinstalled Roon on the Mac Mini, and Roon ARC is up again at least for now. We’ll see…

Hi @Sean_Pierce,

The symptoms you’ve described resemble a potential backend server issue that we’ve encountered sporadically in the last few weeks. If the encounter the spinning loop again (and restarting Roon/ARC doesn’t help), please let us know. Otherwise, this type of behavior should dissipate before too long.

Yes, it seems that the spinning loop has returned…

I have the same issue here. After the spinning wheel times out I get a RETRY option saying “To connect, make sure your Roon Core is turned on and configured for remote access.”

1 Like

For what it’s worth, the latest Roon/ARC updates did not break my setup - with no change in the FIOS G10000 port forwarding that I’d set up as described in the other thread (Verizon FIOS - Quantum Gateway Router G1100 Solve "Poor Connection" Issues with Manual UDP Rule), ARC continues to work as expected.

Hi @Sean_Pierce and @Tyrone_Milton,

The team can reproduce the symptoms you’re reporting. We have an open investigation and will resolve the underlying server-side issue as soon as possible. We don’t anticipate you should continue to experience these problems for long, as we’ll stabilize the backend processes responsible for the loss of service.

Other users have resolved the issue or found a reprieve from the spinning port forwarding test by 1) rebooting their Core device fully and/or 2) uninstalling and reinstalling ARC and fully deleting data. If you’ve already tried these steps, please try once or twice more and let us know the result. In the meantime, we’ll keep you posted as our internal efforts to resolve the situation bear fruit. Thank you!

What do you mean by “uninstalling and reinstalling ARC and fully deleting data?” Are you saying we should try deleting our entire ROON database then starting again from scratch? That seems like a rather draconian solution. Or did you mean to delete the ARC app from our mobile devices? I don’t know how to delete ARC by itself otherwise. (Note, I also have an open support thread on what I think is the same issue.)

Hi @Eric_Olson,

On iOS, deleting Roon ARC will prompt the option to fully uninstall and delete the app’s data from the phone. On Android, just uninstall and reinstall the app, and delete the app’s data in Settings - Storage, depending on your version of Android.

If you have a significant volume of local content downloaded to the phone, you’ll need to redownload these tracks to your mobile device in ARC when ARC resyncs to the Core again after reinstalling. This is similar to hitting “Reset Roon ARC” within the app.

All of the above steps differ from a Roon database refresh, which would require restoring a Backup to not wipe out your library and customization. There’s no need to refresh your database in this case.

If reinstalling ARC isn’t successful, you can reboot the machine hosting your Roon Core. Since the server outage manifests in the short term as an authentication failure - and subsequent hang - restarting can refresh underlying conditions and sometimes bypass the issue.

Hi. I am still experiencing this problem. I cant connect to Roon Arc on my Android phone and Roon settings on my PC Roon Arc is showing “Testing…” only. This has been the situation for over 24 hours. Any ideas when this will be resolved.


1 Like

I also have this problem with Google Nest WIFI and ethernet

UPDATE (March 3) : I had previously deleted the iPhone APP and it didn’t work. I deleted it again and this time I got the proper display back but the Mac Server Roon Settings / ARC showed "Not Ready.

So I closed all Roon players and servers and restarted and all is well again.

Everything seems to work (fingers crossed)

Thank you for your comments. I deleted the iOS App (and associated data), then reinstalled the App. After logging back in, I now just see a screen that says “No Roon Cores found.” This solution did not work.

As indicated in my main support thread, on the Roon Remote, Roon ARC is stuck in the “Testing” loop, and none of the suggested solutions from other Roon users have seemed to make any effect.

I reconnected my Rooncore, reinstalled ARC, now everything working fine again, pew :sweat_smile:
Very inconvenient when you’re elsewhere not able to reset your core.
Hope this won’t happen again in future updates…

Thanks for all the comments. The problem of Roon Arc stuck in “Testing” loop has persisted for me. I have tried all the suggested workarounds and they have not solved the problem. It would be good to have some idea as to the timeframe for this to be resolved.


Thanks to the support team for the follow-up. After rebooting/reinstalling the network, core, and Roon ARC, it seems like Roon ARC functionality has been restored once again.

I must say it has been quite a journey following the migration from Roon 1.8 to Roon 2.0 and Roon ARC, delving into network issues that personally I find interesting, but others may find off-putting. I hope that overall enthusiasm for the product does not suffer. On a positive note, the most recent updates have apparently addressed stability issues over WiFi, and the interruptions when streaming to grouped endpoints (particularly over AirPlay) have seemingly resolved, for which I am immensely grateful. The system now appears solid.

While I have your attention, if we could now address those nagging UI issues like the lack of a volume slider for grouped zones, and the inability to select individual endpoints in a group rather than having to ungroup and regroup, life would be grand…:wink:

Just tried rebooting PC and opening roon and then reinstalling arc on my android phone. Roon still spooling ‘Testing’ and arc now nothing but a white screen and logo. Please help ! Need tunes tomorrow for my long run… This is truly depressing.

I have a similar issue. Core won’t recognize Arc. Android phone and Fiio M11 Plus won’t recognize Arc. Wheel spins incessantly. All have been uninstalled, and then re-installed. Still nothing.


Some users set up seems to have fixed itself and radio silence from tech worries me…


I am having the same issue, ARC has been working just fine but now won’t connect on the mobile app. When I check on Roon Core just a spinning ‘Testing’.

Tried restarting everything but no improvements.

Is this an update issue or is it my end?