ARC Not Working Since Update 1223 [Fixed in core build 1232]

Roon build 1226 early access 64 bits on this version roon arc gives a spinning wheel and does not connect.

For me, I set a single port forwarding rule for ROON and setting the same port for the internal and external port for TCP and UDP protocol with the same port that I have set inside of ROON for ROON ARC. Once I did that, mine has been working since then without any issues for the last 3 days. Not sure though if it varies from router to router though with how it all works together depending on what other settings there are set for the router already. But this solution fixed mine 100%.

Day 8. Same as the previous 7. Testing loop. None of the workarounds work for me.


1 Like

Tried again yesterday. Roon on Windows PC still ‘Testing’ spooling; Roon Arc app on Android phone spinning wheel, not connecting, telling me to ‘make sure your Roon Core is turned on and configured for remote access.’ Hope the update comes soon.

Hi All. My Roon Arc is now out of the Testing loop and is showing as Ready. Hopefully this a permanent fix to the issue.


Hi everyone,

The team continues to investigate the underlying issue here. Some users may experience reduced symptoms now that server stability has been restored; other users may continue to be affected for the time being until we release an additional fix.

We’ll provide an additional update as soon as we have a more precise timeline to resolution.


After restarting the server and router I do now have a Core IP address and only one configured port in the router settings but, as you can see still no working Arc :triumph:

Same issue here. Rebooting the Roon core works for about 24 hrs. New day, same problem.

Yes, same here. Now i have to plug in and out Nucleus every 12 hours to get connection to ARC again…

Thank you, Connor. That is very helpful information, and goes a long way as far as expectation-setting. Much appreciated.


1 Like

I hired an IT guy. He set up a port forwarding protocol and rebooted my server. It works great now. A shame you have to be a techie but maybe things will become easier in time. I really like ARC.

Same here. It will not connect to my core…error log display
“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“XX.XXX.XXX.XXX”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“XXX.XXX.XX.X”,“found_upnp”:true,“error”:“doaction request return statuscode: UnknownError”}

Similar problem

“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="\” s:encodingStyle="\“>\n<s:Body>\n<s:Fault>\ns:Client\nUPnPError\n\n<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">\n501\nPAL_UPNP_SOAP_E_ACTION_FAILED\n\n\n</s:Fault>\n</s:Body>\n</s:Envelope>\n”}

I followed the instructions here to set up port forwarding and now it’s working perfectly.

Many problems today with Roon ARC early access, Roon ARC and Roon software in general.
Overall after many attempts to correct, I have determined that 1223 is just bad. Now I am getting crashes or hangups on all all devices including a iphone 11 pro max and a Macmini 8,1 with Intel Core i5 32 GB

I am running ROCK on a i7NUC with approximately 10000 tracks. This whole experience is a disappointment, when last year I became a lifetime subscriber. I believed in the company as they had made tremendous progress after a few years in getting Hegel Roon Ready. Personally, for those of you on the yearly or monthly plan, just stay there.

Plus I had similar connection issues as Kevin_Smith and Rob_Higginson, unfortunately I was not able to capture the screenshot.

After having those connection issues, I did reset Roon Database & Settings and then restored a database backup. For right now, I am using Roon only on my MacMini but expect to play music in other zones this evening. Right now the software (remote) appears to be working. I will report if I have any other crashes or error messages.

Hi all, I had to manually configure my port on the router, which is strange as it sorted itself originally, and now all is well at last. Thanks to all who advised.

Thanks I was aware of it, tried it it didn’t work! Retried it and fine now thanks.

I retried reconfiguring the port forwarding on my router which led to the crashes on my Mac mini. I plan to do a complete reinstall today of the ROCK & manually reconfigure to ports on the router.

Okay so we’re just gonna pretend that manual configuration is the path forward. Why? I’ve never had to do that before. And maybe it’s me…instructions are convoluted…I can’t navigate it. It looks like my router is already set up for auto config…& has been since I’ve purchased it. The only thing that has changed was the recent software update for devices. After that the following issue appeared.
upnp_autoconfig": {“server_ip”:“..**.*”,“found_upnp”:true,“error”:“doaction request return statuscode: UnknownError”}

I’ve checked my router and it is set up on auto config. So dunno what gives. Hopefully a fix will be put into play this week.

Logged into RoonArc today after not touching it for several days, prepared to reset the entire system, as necessary. Surprisingly, “Testing” completed without any intervention, and the system appears operational. Again, fingers crossed, and time will tell if the system is stable…