ARC not working with Apple Carplay

This is a continuation of a previous post but topics are closed so quickly there’s barely time to reacy. Can’t we keep topics open for at least a week ?


Anyway, since my ISP managed to open the designated port for ARC, it has performed perfectly on my Apple Iphone 12. However . . .

Getting it to work in the car ( with USB connection to Audi’s MMI and Apple Carplay) is a different matter. So, this morning I connected the phone - Carplay appeared as an option in the MMI and the usual functions, like Google Maps etc, work just fine. There’s obviously no connection problem.

But all ARC can manage is to continue playing the playlist I last looked at on the mobile (City and Colour today). I’ve no other options available - all I get are error messages when trying to open anybtab on the top line.

I’ve attached photos (you may need to zoom in).
Are there settings I need to check ? Mobile data is on and signal strength varies from 2 bars of 3g to 2 bars of 5g depending on where I am.

I just can’t see anything else to tweak.

Normally they stay open longer, but your last post in the other thread was marked as “Solution”, and in this case they autoclose after a few days (which seems sensible if correctly marked as solved)

Typically, #support threads remain open for a month after the last post, unless the thread is marked solved.

I’ve posted details about failing to get ARC to play in my wired CarPlay vehicle (see ’ ARC not working with Apple Carplay’ in ARC Port Forwarding category.
But cannot find a solution on the Community platform - surely someone else is using ARC with CarPlay ?).
I’ve emailed ROON directly but not even received an acknowledgement. Depending on the Community to resolve everything is surely going a step too far and ROON need to step in directly at times ?

In summary ARC works perfectly on my iPhone 12. The phone connects to my Audi’s MMI and I can use all the other functions, such as Google Maps. But when it comes to ARC all it will do is continue to play whatever playlist was on the phone before connection. No ability to select anything else, change any settings. My post (above) shows photos.

Thanks and come on ROON !!!

I’ve merged your plea for help into your existing support thread, because opening a new topic for your issue will actually slow things down.

Support is given by the Support team here in the Support categories of the forum (e.g. #support, #support:port-forwarding-help, #support:nucleus-support ) and not via email or telephone.

The Support team is small (less than a handful of people), they don’t work weekends, and they have a long queue of issues that they work through. That is why posts in the Support categories are public, so that Community members who have solutions to issues can jump in and cut the waiting time for the Support team to reach the issue in their queue.

For your issue, there are two possibilities:

  • either no other Carplay user is experiencing the issue, in which case you should give as much detail about your particular setup (i.e. Core and ARC builds, who your ISP is, etc.); or
  • ARC does not yet support the playlist functionality that you are seeking. Not being a Carplay user myself, I cannot confirm this, but perhaps if other Carplay users are seeing this, they could respond in this topic thread…

Sorry Geoff but, given that ROON designed ARC and the interface with CarPlay, and advertise it as a fully working function, the designers should KNOW exactly what functionality it is supposed to provide.
Expecting customer’s experience of issues and actions is one thing but at best it can only be subjective.
This is not a minor annoyance but an absolutely fundamental requirement of ARC - if I cannot use it in the car then ROON should be clear about that. ROON advertising for the CarPlay functionality is NOT what I am getting.
Anyway, thanks for their merge.

PS - can we have a separate category for ARC with CarPlay (and Android) so at least we are not trying to search every aspect of ARC. Thanks

Having similar issues. ARC works fine on my iPhone but not when wired to Apple CarPlay. All it manages is to play whatever was last on the iPhone (eg one playlist). I’ve no ability to search or select tracks or anything else - screen just tells me ‘Something Went Wrong’ !
Has ANYONE got ARC to provide proper functionality with CarPlay ? If so at least that would confirm that ARC is supposed to be comprehensive and not just a connection to the phone where you have to use the phone to navigate ROON.

1 Like

I use ARC primarily with CarPlay. I can’t say that ARC has been flawless, but overall it’s ok. I’ve has some issue with cover art not displaying correctly. I’ve also had a few quirks with ARC resetting itself. The latter started after I enabled 2FA on my Roon account. After removing ARC, logging out of Roon, logging in again and reinstalling ARC I’ve not had issues. :crossed_fingers:

Fromwhat I’ve read, the quality of the cable could have an impact on how well CarPlay is working.

So, should I see pretty much the same functionality as on the ‘ phone ?
All I get is the Now Playing screen which will play whatever was chosen on the Iphone before it was connected.
Oh, I do get the previous search / options screen but it holds no data and just has error messages “Something went wrong”

It’s more limited than ARC on the iPhone, but does have albums, artists and playlists. Although I do believe that these lists are more limited due toe CarPlay limitations.
My primary use case is dedicated playlist for ARC, which is downloaded to the iPhone.

When it works it works well with all the features mentioned.

I find it has a problem if started in an area of poor cell service or when the phone is switching from Wi-Fi to cell - typically when I am leaving home. This leads to an issue that seems resolved only by switching the phone off and restarting…

I find if I am not in a hurry and can wait for the buffer to fill before leaving the garage and into my local terrible cell phone service - things work much better.

It’s not perfect but is steadily improving.

Well, if I operate ARC from the phone, all is fine and I get audio through the car’s MMI. If I look at Apple Carplay / ARC on the cars display I can get two screens; the first (should show top line tabs with ‘Library’ etc) shows nowt except ‘Something went wrong’. The second screen is the Now Playing screen which displays correctly, complete with artwork.
But of course, having to operate from the phone ( eg to search and select music) is no use as it is illegal to use a mobile in the car with the engine running here in the uk.

I would guess this is a cable problem, especially if ARC works on the phone. Can somone with the problem go into ARC settings and chang the playback quality from automatic (default) to a low quality and see if it fixes the problem?

Ok. I’ve tried four different cables in two USB sockets - no difference.
However, I may have been fooling myself and unwittingly using a wifi connection twixt core and phone (I’m parked outside my house). So I’ve now turned wifi ( and bluetooth’ off on my Iphone 12.
With 2 bars of a 4g signal I get connected but seem stuck on the screen below. What is supposed to happen next ? If I just wait the connection just keeps resetting.

PS the photo was bad timing and I managed to snap the resetting view. From here it just goes to an IMac online and ready status with a green button.

Got the Iphone working via the mobile signal last night - 2 of 4 bar signal strength at 4G. Hooray - took a few minutes to get going mind.
Repeated the test this morning, same signal strength - ‘Poor Connection’ is all I get.
Yet the phone is perfectly happy making and receiving calls, searching the web etc.
Does ARC require a certain ( excellent) signal strength to work ?
I just don’t understand what the problem is.
Rapidly heading to a decision not to renew my Roon membership later this year as their support is appalling ( less than 5 support staff for thousands of subscribers). Just look at the scores of unresolved queries on ARC alone.
The community approach is good for some things but not for technical stuff that, I guess, a minority of users even understand.
Grrrrr

Well, what a difference a day ( or two) makes !
Not driven the motor for a couple of days but set off this morning and plugged the phone in as usual, not expecting very much. Especially when all I had was two bars of 3G signal.
Well, knock me sideways with a wet kipper . . . for the first time EVER, ARC was showing the home page (library, downloads etc) on my Audi’s MMI. And it played as it should on the Now Playing screen. Even when I lost signal a couple of times ARC re-connected and continued where it left off.
Why ? I’d not changed a single thing. Has there been a Core update in the last 72 hours I don’t know about ? Will it work tomorrow ? So hope it does . . .

Hi @Stephen_Judge,

Thank you for your post and for your patience. We’ve merged your more recent posts in another user’s thread to a single place where we can troubleshoot as needed.

ARC has multiple fail safes to accommodate fluctuations in connectivity during expected driving scenarios. These should prevent most symptoms except artwork loss (albums might appear as grey squares) and the occasional long loading time in between tracks. Even if you lose sight of the RoonServer machine intermittently - whilst having zero bars in a tunnel, for instance - ARC ought to recover.

So, something else has been at play here.

Reviewing diagnostics from the period during which connectivity was failing for you, the most likely culprit appears to be an upstream connectivity issue between your RoonServer machine and the internet.

You’re correct that we’re familiar with problems affecting standard kit, but we do need to know what kit you’re using in order to diagnose what’s wrong. Your Core is on MacOS (an iMac, I assume?), but are you using a hardwire ethernet connection, or WiFi connection, to reach the internet? If the latter, try an ethernet connection instead, as it’s likely to relieve these problems.

Do you have any network hardware other than your main router in your setup? What about network switches, mesh nodes, or access points?

Another tip we recommend to help with upstream connectivity - try entering your router’s web administration page and changing the DNS server assignment to Google DNS. Roon ARC relies on more than just your RoonServer and the phone - it also needs to call a wide number of external internet addresses to function (such as Roon’s own servers). This step should help resolve those addresses more efficiently to speed up your response time.

We await your response and we’re here to help further. Thank you!

Connor- I use a dedicated m1 Mac mini as a server running Roon which is also hooked up by Ethernet. I have a 1.2Gb network. Most of the time it works. A lot of the time when it doesn’t work, running arc on the iPhone works fine. I do have a wired deco mesh network.

I’m not sure if I want to change dns to the Google dns.
Thanks

Just responding that this has now happened for me! Behaving perfectly as expected - great commutes the last couple of days listening to a constant steam of music. Lets hope I don’t jinx it by responding here, but its a remarkable improvement.

Was thinking - wouldn’t it be great if I could “like” and mark for “down load” from the car play interface?