Arc not working (Zyxel VMG8825 w/ Netgear Orbi)

Roon Core Machine

NUC with ROCK 16gb

Networking Gear & Setup Details

Netgear Orbi router RBR50v2 and Zyxel VMG8825-t50

Connected Audio Devices

NAIM unity nova

Number of Tracks in Library

Only streaming

Description of Issue

I have tried using ARC but I cannot connect form outside the WiFi. I Have set port forwarding on my Netgear Orbi that I use to extend my wifi and on my Zyxell router/modem and enables UPnP on both, but it will not work. Can anyone help? Here is my diagnostics:
{
“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect EHOSTUNREACH xxxx:55000, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“xxxx”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“10.0.0.1”,“found_upnp”:true}
}

Who is your ISP, and are they providing you with a public (visible on the whole internet) IP address, or is your external IP address known only to your ISP?

I had the same issue, with an Orbi6 router.
The root cause was a double router: (i) the ISP’s modem/router with (ii) the Orbi router.

The solution was to activate bridging on my ISP’s modem/router; basically, the router functionality of the ISP modem/router is de-activated and the Orbi remains the only router. You also need make sure that UPnP is turned on the Orbi router (via advanced settings on the Orbi router menu → 192.168.1.1)
I was able to active the bridging functionality on my ISP’s device by logging in to my account page on the IPS’s portal. Note: it’s not real bridging but MAC forwarding: I specified the MAC address of the Orbi router in my ISP’s modem/router setting.
Next, restart the ISP modem/router (I just pulled out the power socket) and also restart your Orbi (also here I just pulled out the plug).
So now I can access my Roon Nucleus from “the Internet”, i.e. I do no longer need to be connected to my home network.

If you are unable to de-activate the router functionality of your ISP’s device, you can also change your Orbi router from Router mode to AP mode (via Advanced Settings); this will have the same effect, i.e. only 1 router between your devices and the Internet.

Hope this helps.

Kind regards

/F

1 Like

Thanks, I will give this a try.

So I tried to find any options on mac forwarding or bridge mode. But I dont think my ISP (Zyxel t50) has that option. I asume this should be done in the ISP and not in the Orbi router?

Also is mac forwarding something different from port forwarding? I also have an option for porttriggering. Or DMZ. But I thought they said that you shouldn’t touch DMZ.

Sorry I am not much of an IT guy…

Hello Xander

Hope you’ve got it working by now. If not, connect your Roon core directly to the modem provided by your ISP. (Via a UTP cable or via Wifi). Restart your Roon core.

This should work.

A post was split to a new topic: Cannot connect Roon ARC to my Core

I tried this. It did not fix my issue. This is also not what I want because I have an output connected directly to my roon rock. Which I can nor use if I connect my roon rock to my ISP modem.

Anyway, thanks for helping. I’ve given up on this after wasting 2 afternoons fiddling around with my setting. Maybe there will be an update later on fixing this issue. Thats ussually how it goes foe me with Roon…

Hi @Xander_Westenberg,

If you still have the patience for one more try, the tech support team has taken a look at your earlier post and we have a few next steps.

The diagnostics you’ve provided suggest that UPnP is enabled on your network, but the connection is being refused at the level of the Zyxell modem or upstream. This is either the result of UPnP not being enabled properly on your router, or settings at the level of your internet service provider.

You can create a manual port forwarding rule.

  • Since you’ve already enabled UPnP, keep it on in both the Orbi and the Zyxell for now.
  • Try to manually open the port in your modem/router’s port triggering configuration. You will need to assign a rule for TCP specifying the static IP address of your Core and the Port Roon has assigned. These will both be listed in the Roon → Settings → ARC tab.
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC. Double check the rule you’ve created.
  • Next, enter the web administration page for the Orbi router and create the same rule. It will be under Advanced → Port Forwarding or something similar.
  • Check for any VPNs or Firewalls that might be interfering.
  • Restart your network hardware.

If you continue to experience difficulties, we recommend reaching out to your internet service provider and passing along the following questions:

  • Have you implemented carrier-grade NAT for my account level?
  • Have you fully implemented IPv6, or do you have IPv4 addresses available?
  • Can I request a static IPv4 address to support port forwarding?
  • Are there any ports you have reserved at the ISP level I should be aware of?
1 Like

Hi @Xander_Westenberg,

I wanted to check in - are you still experiencing issues here? I hope you’re enjoying ARC and no longer need this thread, but we’re standing by to assist if necessary.