ARC Port forwarding issue (ASUS router)

Thanks for your fast reply and hint…
However, i am in firmware version 48260, no NAT type in there apparently

weird, according to asus it was added from 386_41700 onwards.

I’m running Asuswrt-Merlin on mine (ax86u)

[Wireless Router] How to change NAT type on ASUS Router? | Official Support | ASUS Global.

Thanks for your suggestion, @Bob_Scratchit. I’ve followed your suggestion:

Unfortunately, I’m still getting the same error message.

Thanks for your suggestion, @Red_R. I’ve followed the steps you’ve outlined and I’m still getting the same error message. I’ve also changed the settings on my Asus router, as per @Bob_Scratchit’s suggestion. Frustrating!

1 Like

I had to add a port forwarding rule in my ISP’s Fibre modem besides my router to get ARC to work.
Forwarded the port (52000 in my case) to my router IP ( in my case).

1 Like

To isolate the problem it would be useful to contact your ISP to find out if you are getting a public ip or a cgnat address.
Cgnat does not allow port forwarding which Roon ARC needs to work. In this case you may be able to get a real IPv4 address from your ISP.

Likewise, no 2 routers with activated NAT should be connected in series in your network. The first router should be in bridge mode or add a port forwarding rule to the second router to avoid a double NAT layer, since ARC port forwarding does not work with it.

Carrier-grade NAT usually prevents the ISP customers from using port forwarding, because the network address translation (NAT) is usually implemented by mapping ports of the NAT devices in the network to other ports in the external interface. This is done so the router will be able to map the responses to the correct device; in carrier-grade NAT networks, even though the router at the consumer end might be configured for port forwarding, the “master router” of the ISP, which runs the CGN, will block this port forwarding because the actual port would not be the port configured by the consumer.

1 Like

So, spent half an hour on phone to Internet provider and had a static IP address assigned - ARC recognised the Core immediately!

1 Like

CGNAT shouldn’t have any impact on local port WAN>LAN forwarding.

Thanks, @Axel_Lesch. I’ve just had a chat with my ISP, BT, and they’ve said that they provide Public IP address to all their residential customers (of whom I am one).

WRT the two routers, both the BT Hub and the Asus ZenWiFi have DHCP servers enabled. Should I disable the DHCP server on the BT Hub (all the wifi is dealt with via the ZenWifi)?


Here’s a guide how to set it up in bridge mode:

1 Like

Thanks yet again, @Axel_Lesch. Unfortunately, I have a BT Home Hub 5. It looks like it’s not possible to put it into bridge mode.

Too bad, mate!

If you’re feeling brave you can remove the BT home hub completely.

I’ve got BT FTTP and it uses PPPoE so I don’t use the hub and just have the ethernet plugged directly into my router.

The PPPoE for all BT home connections are:

Password BT

I am using Zenwifi AX, I have the same problem that Roon ARC is not able to connect to the Core. I have tried all the tips mentioned above, did I miss any :

  1. NAT Type change to Fullcone,
  2. Manual input the port forwarding with both external port and internal port put 55002, use protocol both and TCP

Something strange has happened. Must be the result of me changing various settings. Now when I try to assign Roon’s user defined IP address, I get a message saying “The host does not belong to any recognized LAN.”

Meanwhile, the error message now reads:

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“doaction request return statuscode: UnknownError”}

Any ideas?

Are you possibly able to restore from memory your previous settings on both devices?
I always take a screenshot of the router configuration before making any major changes.
It’s difficult to say anything helpful from a distance as we can’t know what you changed and how the settings for both devices now work together.
Did you backup your Asus router so that you can at least restore the Asus to previous settings?
If you have changed something in the DHCP settings on one or both routers, this may be the cause.

I have put my modem/router to bridge mode, which solved the issue for me.

His router can’t be set into bridge mode

I have the exact same error message on my 4G-AC68U router. Hoping for someone to “decode” it