ARC port forwarding issue with SGC sonic transporter and Linksys router

Roon Server Machine

I am using a new Small Green Computer SonicTransporter i9, with Roon Server version 2.0 (build 1359)

Networking Gear & Setup Details

  1. Who is your internet service provider?
    Internet from Verizon FIOS

  2. Please list the make and model of your modem and router?
    LinkSys WHW03 v2

  3. Do you have any additional network hardware, like additional routers or managed switches?
    no managed switches

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?
    o

Connected Audio Devices

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

I get this error code:

{
“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect EHOSTUNREACH 141.aaa.bbb.ccc:55002, response code: undefined, body: undefined”},
“ipv6_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“141.aaa.bbb.ccc”,“actual_external_ipv6”:“2600:ddd:eee:fff:ggg:hhh:iii:jjj”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“10.10.10.1”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“>\n<s:Body>\n<s:Fault>\ns:Client\nUPnPError\n\n<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">\n501\nPAL_UPNP_SOAP_E_ACTION_FAILED\n\n\n</s:Fault>\n</s:Body>\n</s:Envelope>\n”}
}

@Peter_Zorn, the diagnostics you’ve provided suggest that UPnP is enabled on your network, but your router is refusing the connection. This is either the result of UPnP not being enabled properly on your router, or settings at the level of your internet service provider.

First, to confirm the issue is not with your local network setup:

  1. Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Roon Server
  2. Try to manually open the port in your router’s port forwarding configuration
  3. Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  4. Check if your modem is in Bridge mode

If you continue to experience difficulties, there may be one other option. The port Roon has reserved for ARC may be in use with another application. Can you try assigning ARC a different port number, e.g., 56000, and see if that works?

1 Like

Thanks for the quick response. These look like great suggestions. I will try them and get back to you with an update. :crossed_fingers:

That worked, thanks. I am up and running on Roon ARC. Had to set up the port forwarding configuration on my router. Appreciate the help!

3 Likes