ARC recognises my Nucleus Core... but fails to see it as soon as I step out the door

Roon Core Machine

iMac 2020 running latest iOS software

![Screenshot 2022-12-03 at 9.53.56 pm|280x500](upload://4JQ49ebm5feGsAkn75Ob1f0lSpr.png)

Add images

Networking Gear & Setup Details

ISP modem TG789vac V2
Netgear Nighthawk RAX80 router on Ethernet

Connected Audio Devices

KEF LS50W on network
KEF LSX on Ethernet connected to iMac

Number of Tracks in Library


Description of Issue

Hi all… I’ve spent the best part of a Saturday afternoon trying to get ARC to see my Roon Core. It’s just not happening and I’m not enough of a Tech Head to see why. ARC works when I’m at home, I can play music through it, but lose connection when I step away from home, which was the whole point of ARC really - being able to access your music from anywhere.

Here is the error message that I get…

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

So far, this is what I’ve tried to do to solve the situation…

• Confirmed that my router supports UPnP and that it is enabled
• Tried a manual static IP configuration on my router as suggested
• Entered the port of 55000 as suggested

I’m running Nucleus connected to a Netgear RAX80 which is also connected to my ISP modem. I mainly use Roon on my mobile phone or iMac.

I’m thinking perhaps there is some issue with having the RAX80-Nucleus-modem all connected although I can’t really see any double-ups in network addresses.

I’ve had enough for one day, the sun is shining out there, time to get away from this problem - hopefully someone can help with a fix.

Many thanks to you all.



It works at home because it uses your home wifi. It fails when it switches to the cellular network.

As you have a modem and a router, probably this:

And what’s your ISP?

Hi SuedKiez,

Well… I can’t believe it! Maybe I got lucky… I unplugged my Nucleus from the RAX80 router and plugged it straight into my ISP modem, restarted and launched Roon and boom! ARC connected straight away. We’re in business.

Appreciate you taking the time to answer my question though and I think you were right in what you suggested… cut out the middle-man (router) and go straight to the source (modem).

I hope this fix can help someone else out there.

Many thanks,


Yeah. If there is a modem and a router, the modem is the external interface to the world. So that needs a a port forwarding from the external IP to the local LAN, which is represented by the router. And then the router must forward it on to the Roon Core.

Or, like you did, remove the modem and make the router (which typically has a modem built in anyway) the external interface. Then you need only one port forwarding from external IP to Core, which is easily configured either by UPnP or manually.

Congrats and enjoy! :slight_smile:

Hi again Suedkiez (and anyone else that might be reading).

This is just a follow up on where I’m at with having ARC recognised by ROON and on my mobile.

So… if you read back a couple of posts… I was having difficulty having ARC recognise my ROON Nucleus Core. I managed to get ARC instantly recognised though by plugging directly into my ISP modem (cutting out the middle-man/router).

The trouble now was that my KEF LS50W speakers were no longer available/visible on my network! These speakers are notoriously flakey with their connection and I’ve never been able to see them appear through my ISP modem (TG789vac V2) which is why I purchased the Netgear RAX80 router in the first place. It could see them ok but when ROON Nucleus was plugged directly into the router ARC was not happy and would not sync properly with the Nucleus ROON Core.

Today I managed to solve the issue by putting the RAX80 router into bridge mode. I was extremely nervous about doing this as I thought I could potentially stuff up the whole network or my apartment might collapse around me! Anyway, it worked like a charm… just went into the interface of the router and clicked on a couple of boxes. Bridging the router makes use of the routers extra coverage but I now only have one network through the ISP modem which ARC is happy with. Before I think, as Suedkiez mentions there was a conflict with dual networks.

Bridging the router loses most of its functionality - it just works as a wi-fi extender and you lose the Guest network features. I only ever really bought it to extend my network signal in the first place so I’m ok with this.

I did consider bridging the ISP modem but when I spoke with iiNet they advised against it as they thought there might be legal issues with them offering tech support after the bridging was done.

Short story long… I’m a happy camper again… my KEFs are visible, ARC is working as are all my other devices that were previously connected via the RAX80 LAN. ROON is working on both computer and mobile, so all good again.

Below are the instructions I followed for Bridging the router, this is for a Netgear RAX80 but I think they would be similar for many routers on the market. Hope this helps someone else out there that is struggling to have ARC and their KEF LS50W’s recognised (I think KEF may have fixed this connection problem with the LS50W II’s. I’m just not prepared to drop another $4K to find out.)

Best regards,


Thanks a lot for the detailed resolution, I am sue it will help other users in the future!
Have fun with ARC!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.