ARC Set-up -- Bewildering!

Can you help? I feel like you need to be an IT expert to get into the network settings of a router. I’m sure that this is surmountable, but just need some help.

I have this error message:

{
“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect ECONNREFUSED 152.ggg.hhh.iii:55000, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“152.ggg.hhh.iii”,“router_external_ip”:“100.aaa.bbb.ccc”},
“status”: “status”: MultipleNatFound
,
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.1.1”,“found_upnp”:true}
}

That error message is saying that there are multiple Network Address Translations existing in your network.
See this article for more information:

Please fill in the information in the form(s) below so that Support can help.

Thanks!

===========================================================

Who is your internet service provider?

Please list the make and model of your modem and router?

Do you have any additional network hardware, like additional routers or managed switches?

Does your network have any VPNs, mesh network, proxy servers, or enterprise-grade security?

What machine are you using as a Roon Core, and how is it connected to the internet?

The diagnostics you’ve provided suggest there is a redundant layer of network address translation preventing port forwarding.

This can either be at the local-network level (commonly as a result of two routers), or at the level of your service provider (in the form of carrier-grade NAT).

If your setup involves an ISP-provided gateway (modem/router combination) and your own third-party router:

  • In the web administration interface of the ISP-provided gateway (modem/router combination), enable Bridge Mode or equivalent, where the ISP-provided gateway does not have DHCP routing enabled.

  • Alternatively, if you have already created a manual port forwarding rule in your 3rd party router, you can add an additional rule to forward the port through the ISP/second router.

If you only have one router in your setup or your modem is already in Bridge mode, please take a look through our list of known router and internet service provider solutions, as other users may have already encountered the same situation: ISPs and Routers: List of Known Solutions and Workarounds

You can reach out directly to your service provider to ask if they support port forwarding; this question will often enough to prompt them to explain whether or not the carrier-grade NAT they’ve implemented can function with ARC.

More specifically, you can pass along the following questions:

  • Have you implemented carrier-grade NAT for my account level?
  • Have you fully implemented IPv6, or do you have IPv4 addresses available?
  • Can I request a static IPv4 address to support port forwarding?
  • Are there any ports you have reserved at the ISP level I should be aware of?

If you’re unable to locate an existing solution in our #support:port-forwarding-resources subcategory, please reach out to the Roon support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

Hi @Simon_Downer,

Did you have an opportunity to follow up on the items as suggested by community leadership?

Is there anything we can assist you with to move this forward?

Thanks,
Wes